Bug 1706382 - Group subcommand should support listing IDs
Summary: Group subcommand should support listing IDs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: 8.1
Assignee: Jaroslav Mracek
QA Contact: Eva Mrakova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-04 14:25 UTC by Michal Domonkos
Modified: 2020-04-28 16:48 UTC (History)
3 users (show)

Fixed In Version: dnf-4.2.16-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:47:49 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 0 None None None 2020-04-28 16:48:03 UTC

Description Michal Domonkos 2019-05-04 14:25:39 UTC
Currently, in order to list group IDs, DNF must be run in verbose mode.  Since using group IDs is arguably much more comfortable than having to always spell out the whole group names whenever operating on groups, forcing users to enable verbose mode to obtain the IDs seems plain wrong (and is a regression against YUM3 which knew the "ids" argument).

That said, we should probably add a new option called "--ids" (with the "ids" fallback for YUM3 compatibility).

Related docs bug:
https://bugzilla.redhat.com/show_bug.cgi?id=1701859

Comment 2 Jaroslav Mracek 2019-10-25 11:57:29 UTC
I create a patch (https://github.com/rpm-software-management/dnf/pull/1513) that implements --ids.

Comment 3 Jaroslav Mracek 2019-10-25 12:23:55 UTC
Tests are available here: https://github.com/rpm-software-management/ci-dnf-stack/pull/665

Comment 9 errata-xmlrpc 2020-04-28 16:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.