Bug 170646 - broken .la files included
broken .la files included
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: synce (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2005-10-13 10:50 EDT by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:52:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2005-10-13 10:50:15 EDT
The synce-devel package isn't stripped of .la files. This causes havoc when
trying to link applications to synce.
Comment 1 Michael Schwendt 2005-10-13 12:42:28 EDT
The initial bug report is misleading. The truth is that the libtool
archives contain _broken content_ (buildroot paths inside the dependencies)
and hence cause problems.
Comment 2 Pierre Ossman 2005-10-13 15:06:22 EDT
Actually, the big problem was that they caused libtool to add -lmimedir. I could
not find this lib anywhere in FC and removing the .la files showed that it was
also completely unnecessary.

I thought the general consesus was that *.la should be removed from all packages
because the cause more problems than they solve?
Comment 3 Michael Schwendt 2005-10-13 15:26:11 EDT
There is no such "general consensus" with regard to libtool archives.
But yes, in many cases they only cause problems and are not needed.
Comment 4 Andreas Bierfert 2005-10-14 07:39:40 EDT
just got back vacations will look into it asap
Comment 5 Andreas Bierfert 2005-11-28 15:52:17 EST
This should be fixed in the current version...

Note You need to log in before you can comment on or make changes to this bug.