Bug 1706653 - Warning for "Some fonts failed to load: - /usr/share/gimp/2.0/fonts/"
Summary: Warning for "Some fonts failed to load: - /usr/share/gimp/2.0/fonts/"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: 29
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Ridky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 00:29 UTC by Tim Landscheidt
Modified: 2019-09-28 00:01 UTC (History)
7 users (show)

Fixed In Version: gimp-2.10.12-3.fc30 gimp-2.10-3020190904121229.a5b0195c gimp-2.10-2920190904121229.6c81f848 gimp-2.10-3120190904121229.f636be4b gimp-2.10.12-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 19:24:25 UTC


Attachments (Terms of Use)
command-line output of gimp --verbose (39.68 KB, text/plain)
2019-08-20 04:24 UTC, talibpierson
no flags Details

Description Tim Landscheidt 2019-05-06 00:29:52 UTC
When executing GIMP (gimp-2.10.10-1.fc29.x86_64), it warns on the command line:

| [tim@passepartout ~]$ LANGUAGE=en_GB gimp
| GIMP-Message: Some fonts failed to load:
| - /usr/share/gimp/2.0/fonts/

| [tim@passepartout ~]$

There is no directory by that name and there appears to be no package in Fedora or RPM Fusion that ships anything beneath that.

The directory was mentioned commented out in the %files section of the original import into dist-git (17a6ecebe292aa35b26eca7021b6627373d587e1), and the comment was subsequently removed by 12b34f5d814d5154c389d746626b0f8fc912be66.

This looks like either the package should ship the (empty) directory or Fedora should patch GIMP to not look for that directory.

Comment 1 Jonathan Wakely 2019-08-08 13:30:26 UTC
Still present in Fedora 30 with gimp-2.10.12-1.module_f30+4715+3a2b846c.x86_64

Comment 2 talibpierson 2019-08-20 04:24:17 UTC
Created attachment 1605947 [details]
command-line output of gimp --verbose

I did this twice to check for consistency. GNU diff reported that the files were identical.

Comment 3 talibpierson 2019-08-20 04:26:51 UTC
Operating System: Fedora 30 (Workstation Edition)
Kernel: Linux 5.2.8-200.fc30.x86_64
Installed Packages
gimp.x86_64 2:2.10.12-2.module_f30+5292+0833adf4 @updates-modular

Comment 4 Josef Ridky 2019-08-20 11:02:14 UTC
This behavior is caused by hardcoded path for fonts in default configuration.

As quick workaround, you can just simply remove /usr/share/gimp/2.0/fonts/ from GIMP configuration
(Edit > Preferences > Folders > Fonts)

In meanwhile, I'll prepare patch with modification of default configuration.

Comment 5 Fedora Update System 2019-09-05 06:30:10 UTC
FEDORA-MODULAR-2019-8a7400233d has been submitted as an update to Fedora 30 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-8a7400233d

Comment 6 Fedora Update System 2019-09-05 06:30:13 UTC
FEDORA-MODULAR-2019-655f35836d has been submitted as an update to Fedora 29 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-655f35836d

Comment 7 Fedora Update System 2019-09-05 06:30:14 UTC
FEDORA-MODULAR-2019-4184d68b11 has been submitted as an update to Fedora 31 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-4184d68b11

Comment 8 Fedora Update System 2019-09-05 06:30:16 UTC
FEDORA-2019-bd9b45452c has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bd9b45452c

Comment 9 Fedora Update System 2019-09-05 10:51:54 UTC
gimp-2.10.12-3.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a935bccb81

Comment 10 Fedora Update System 2019-09-05 12:53:02 UTC
gimp-2.10.12-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bd9b45452c

Comment 11 Fedora Update System 2019-09-05 14:15:41 UTC
gimp-2.10-2920190904121229.6c81f848 has been pushed to the Fedora 29 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-655f35836d

Comment 12 Fedora Update System 2019-09-05 14:17:04 UTC
gimp-2.10-3020190904121229.a5b0195c has been pushed to the Fedora 30 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-8a7400233d

Comment 13 Fedora Update System 2019-09-11 19:24:25 UTC
gimp-2.10.12-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2019-09-12 22:37:54 UTC
gimp-2.10-3020190904121229.a5b0195c has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-09-13 00:14:28 UTC
gimp-2.10-2920190904121229.6c81f848 has been pushed to the Fedora 29 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-09-16 02:30:58 UTC
gimp-2.10-3120190904121229.f636be4b has been pushed to the Fedora 31 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-4184d68b11

Comment 17 Fedora Update System 2019-09-24 01:42:17 UTC
gimp-2.10-3120190904121229.f636be4b has been pushed to the Fedora 31 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-09-28 00:01:48 UTC
gimp-2.10.12-3.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.