Bug 17067 - mkinitrd does not seem to work....
mkinitrd does not seem to work....
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-29 06:51 EDT by adler
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-29 11:05:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2000-08-29 06:51:13 EDT
I installed pinstripe a while ago, just after it came out. I got a new
Adaptec AIC-7892 Ultra 160/m SCSI host adapter and ran the mkinitrd command
in order to create a new initrd image so that when the kernel booted, it
would load both my Buslogic and Adaptec drivers. Well, the kernel did not
load any of the two. What worries me is that since you guys have depricated
/etc/conf.modules in favor of /etc/modules.conf (ugg....) I'm wondering if
mkinitrd is looking at the wrong file. The man page for mkinitrd references
/etc/conf.modules and not /etc/modules.conf. Here look....

MKINITRD(8)                                           MKINITRD(8)

NAME
       mkinitrd  -  creates initial ramdisk images for preloading
       modules

SYNOPSIS
       mkinitrd [-fv] [--with=module] [--preload=module]
                [--omit-scsi-modules] [--omit-raid-modules]
                [--version] [--fstab=fstab] image
                kernel-version

DESCRIPTION
       mkinitrd creates filesystem images which are suitable  for
       use  as Linux initial ramdisk (initrd) images. Such images
       are often used for preloading  the  block  device  modules
       (such as SCSI or RAID) which are needed to access the root
       filesystem.    mkinitrd    automatically     loads     all
       scsi_hostadapter entries in /etc/conf.modules, which makes
       it simple to build and  use  kernels  using  moduler  SCSI
       devices.

       Any  module  options  specified  in  /etc/conf.modules are
       passed to the modules as they are loaded  by  the  initial
       ramdisk.


In anycase, it could be that something else is mucked up. I'll be glad to
assist in helping debug this problem.

Cheers. Steve.
Comment 1 Bill Nottingham 2000-08-29 11:05:17 EDT
mkinitrd definitely looks in modules.conf, and the man
page has been updated to reflect this in a later release.
Comment 2 Erik Troan 2002-05-20 22:52:43 EDT
this bug dies of old age.... reopen if it's still applicable

Note You need to log in before you can comment on or make changes to this bug.