Bug 1706713 - Ansible playbook is failing for ceph-osd task
Summary: Ansible playbook is failing for ceph-osd task
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Uday kurundwade
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 06:56 UTC by Uday kurundwade
Modified: 2020-01-31 12:46 UTC (History)
10 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc7.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:45:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3932 0 'None' closed ansible: remove private and static attribute 2020-10-19 08:06:59 UTC
Github ceph ceph-ansible pull 3933 0 'None' closed Automatic backport of pull request #3932 2020-10-19 08:06:59 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:10 UTC

Description Uday kurundwade 2019-05-06 06:56:09 UTC
Description of problem:
Ansible playbook is failing for ceph-osd task

Version-Release number of selected component (if applicable):
ceph-ansible-4.0.0-0.rc3.10.ga718ddec.el8cp.noarch
ansible-2.8.0-0.8.rc1.el8ae.noarch

How reproducible:
Always

Steps to Reproduce:
1.run ansible-playbook site.yml 
2.
3.

Actual results:

ERROR! 'static' is not a valid attribute for a TaskInclude

The error appears to be in '/usr/share/ceph-ansible/roles/ceph-osd/tasks/main.yml': line 69, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: include_tasks scenarios/lvm.yml
  ^ here



Expected results:
Playbook should complete successfully.

Additional info:

Comment 7 errata-xmlrpc 2020-01-31 12:45:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.