Bug 1706750 - The installer-gather.sh fails to collect some logs for the permission problem
Summary: The installer-gather.sh fails to collect some logs for the permission problem
Keywords:
Status: CLOSED DUPLICATE of bug 1708307
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: ---
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 08:54 UTC by sheng.lao
Modified: 2019-05-13 06:01 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-13 06:01:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description sheng.lao 2019-05-06 08:54:42 UTC
Description of problem:
The installer-gather.sh fails to collect some logs for the permission problem.

Version-Release number of the following components:
# ./openshift-install version
./openshift-install v4.1.0-201905032232-dirty
built from commit e05263cfc7bdf305612f5b78fe91a16cbfea4ce6
release image registry.svc.ci.openshift.org/ocp/release@sha256:6a5dd3e5df1e11a464fa5f0e9ccdcff2d60baa96e11b196948094761d702bb97

How reproducible:

Steps to Reproduce:
1. openshift-install create cluster --dir test
2. enter 'ctrl-c' to break openshift-install to simulate the failure scenario
3. use the sub-command 'gather' to collect information, as follows:
    # ./openshift-install gather bootstrap --dir test
INFO Use the following commands to gather logs from the cluster 
INFO ssh -A core@11.22.33.44 '/usr/local/bin/installer-gather.sh 10.0.141.243 10.0.157.184 10.0.167.252' 
INFO scp core@11.22.33.44:~/log-bundle.tar.gz . 
    # ssh -A core@11.22.33.44 '/usr/local/bin/installer-gather.sh 10.0.141.243 10.0.157.184 10.0.167.252'
  
Actual results:
# ssh -A core@11.22.33.44 '/usr/local/bin/installer-gather.sh 10.0.141.243 10.0.157.184 10.0.167.252'
    cp: cannot open '/var/opt/openshift/auth/kubeconfig' for reading: Permission denied
    ... ...
    find: ‘/tmp/artifacts/rendered-assets/openshift/mco-bootstrap/bootstrap’: Permission denied
    ... ...
    find: ‘/tmp/artifacts/rendered-assets/openshift/mco-bootstrap/bootstrap’: Permission denied

Expected results:
Skip the files from which we can't read 
or escalate the authority to collect information

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 sheng.lao 2019-05-13 06:01:21 UTC
It's fixed in https://bugzilla.redhat.com/show_bug.cgi?id=1708307

*** This bug has been marked as a duplicate of bug 1708307 ***


Note You need to log in before you can comment on or make changes to this bug.