Bug 1706770 - [OSP15] NTP service is still incorrectly referenced in roles
Summary: [OSP15] NTP service is still incorrectly referenced in roles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Alex Schultz
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 09:44 UTC by Vadim Khitrin
Modified: 2019-09-26 10:50 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190509160423.4dac4dc.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1827676 0 None None None 2019-05-06 09:44:21 UTC
OpenStack gerrit 657604 0 None MERGED Use timesync service 2021-01-15 17:16:22 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:56 UTC

Description Vadim Khitrin 2019-05-06 09:44:22 UTC
Description of problem:

'OS::TripleO::Services::Ntp' is still referenced in the following roles instead of 'OS::TripleO::Services::Timesync':

CellController.yaml
ComputeOvsDpdkSriov.yaml
ComputeOvsDpdkSriovRT.yaml
ControllerOpenstack.yaml

Using 'OS::TripleO::Services::Ntp' will cause the deployment to fail due to an attempt to sync with NTP server will be performed by 'ntpdate' command instead of chronyd.

ntpdate is not available in the yum repos supplied as part of RHEL8 Overcloud image.

Ansible log failed deployment due to 'OS::TripleO::Services::Ntp' on 'ComputeOvsDpdkSriov': https://launchpadlibrarian.net/422124386/asible_ntp_failure.log

Version-Release number of selected component (if applicable):
rpm -qa | grep tripleo
ansible-role-tripleo-modify-image-1.0.1-0.20190422122515.f1dfdc6.el8ost.noarch
openstack-tripleo-heat-templates-10.5.1-0.20190426040357.0b61dd0.el8ost.noarch
puppet-tripleo-10.4.2-0.20190426000346.bc825d0.el8ost.noarch
openstack-tripleo-common-containers-10.7.1-0.20190426083235.1988c18.el8ost.noarch
python3-tripleoclient-heat-installer-11.4.1-0.20190424070351.41fa2fc.el8ost.noarch
openstack-tripleo-validations-10.4.1-0.20190426070346.e774685.el8ost.noarch
python3-tripleo-common-10.7.1-0.20190426083235.1988c18.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190424070351.41fa2fc.el8ost.noarch
openstack-tripleo-image-elements-10.4.1-0.20190426080346.7efbd4c.el8ost.noarch
openstack-tripleo-common-10.7.1-0.20190426083235.1988c18.el8ost.noarch
ansible-tripleo-ipsec-9.1.1-0.20190422122014.8c1fdab.el8ost.noarch
openstack-tripleo-puppet-elements-10.3.1-0.20190426070355.a359301.el8ost.noarch

How reproducible:
always

Steps to Reproduce:
1. Attempt to deploy Overcloud with generated roles_data for ComputeOvsDpdkSriov role (or others)

Actual results:
Deployment fails

Expected results:
Deployment passes

Additional info:

Comment 2 Vadim Khitrin 2019-05-14 05:36:07 UTC
Verified on compose: RHOS_TRUNK-15.0-RHEL-8-20190509.n.1

Comment 5 Alex Schultz 2019-05-23 14:00:21 UTC
Not a blocker because the workaround would be to replace the defined Ntp service with OS::TripleO::Services::Timesync. The roles this was missing on were not the default services as well.

Comment 7 errata-xmlrpc 2019-09-21 11:21:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.