Bug 1706782 - [OSP15 ] - Podman service is not used in certain roles
Summary: [OSP15 ] - Podman service is not used in certain roles
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 10:07 UTC by Vadim Khitrin
Modified: 2019-09-26 10:50 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190521220357.dd20049.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1827724 0 None None None 2019-05-06 10:07:08 UTC
OpenStack gerrit 657273 0 None MERGED Enable Podman Service For Lacking Roles 2020-01-24 15:18:55 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:56 UTC

Description Vadim Khitrin 2019-05-06 10:07:08 UTC
Description of problem:

The following roles do not include 'OS::TripleO::Services::Podman':
CellController.yaml
ComputeOvsDpdkSriov.yaml
ComputeOvsDpdkSriovRT.yaml

Which will cause the deployment to fail due to certain parameters not being applied, for example:
In a scenario where tls is not enabled and 'DockerInsecureRegistryAddress' is not being applied to those roles, will cause Podman to fail to retrieve images.

Log of failed Overcloud deployment task: http://paste.openstack.org/show/750583/

Log of Overcloud environment files auto generated: http://paste.openstack.org/show/750582/

Version-Release number of selected component (if applicable):
rpm -qa | grep tripleo
ansible-role-tripleo-modify-image-1.0.1-0.20190422122515.f1dfdc6.el8ost.noarch
openstack-tripleo-heat-templates-10.5.1-0.20190426040357.0b61dd0.el8ost.noarch
puppet-tripleo-10.4.2-0.20190426000346.bc825d0.el8ost.noarch
openstack-tripleo-common-containers-10.7.1-0.20190426083235.1988c18.el8ost.noarch
python3-tripleoclient-heat-installer-11.4.1-0.20190424070351.41fa2fc.el8ost.noarch
openstack-tripleo-validations-10.4.1-0.20190426070346.e774685.el8ost.noarch
python3-tripleo-common-10.7.1-0.20190426083235.1988c18.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190424070351.41fa2fc.el8ost.noarch
openstack-tripleo-image-elements-10.4.1-0.20190426080346.7efbd4c.el8ost.noarch
openstack-tripleo-common-10.7.1-0.20190426083235.1988c18.el8ost.noarch
ansible-tripleo-ipsec-9.1.1-0.20190422122014.8c1fdab.el8ost.noarch
openstack-tripleo-puppet-elements-10.3.1-0.20190426070355.a359301.el8ost.noarch


How reproducible:
always

Steps to Reproduce:
1. Attempt to deploy Overcloud with generated roles_data for ComputeOvsDpdkSriov role (or others)

Actual results:
Deployment fails

Expected results:
Deployment passes

Additional info:

Comment 3 Alex Schultz 2019-05-23 14:07:16 UTC
Not a blocker because it can be worked around by adding OS::TripleO::Services::Podman to the affected roles.

Comment 7 errata-xmlrpc 2019-09-21 11:21:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.