Bug 1706867 - [marketplace] Incorrectly reporting OperatorStatus degrading when restarting or upgrading marketplace operator
Summary: [marketplace] Incorrectly reporting OperatorStatus degrading when restarting ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Alexander Greene
QA Contact: Fan Jia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 12:24 UTC by Kevin Rizza
Modified: 2019-10-16 06:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Marketplace ClusterOperator reports degraded when restarting or upgrading marketplace operator. Consequence: The OpenShift upgrade tests are failing. Fix: Don't report degraded when the operator is stopped. Result: The OpenShift upgrade tests are passing again.
Clone Of:
Environment:
Last Closed: 2019-10-16 06:28:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:28:47 UTC

Description Kevin Rizza 2019-05-06 12:24:54 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kevin Rizza 2019-05-06 12:27:43 UTC
When the marketplace operator is stopped and restarted, it should not implicitly mark the ClusterOperator status as degrading.

Comment 2 Aravindh Puthiyaparambil 2019-05-06 17:49:37 UTC
https://github.com/operator-framework/operator-marketplace/pull/179/

Comment 3 Fan Jia 2019-05-08 05:41:05 UTC
test env:
cv:4.1.0-0.nightly-2019-05-08-012425
marketplace commit:aa37f1c1dafd0fd7faadd2a6b4c41f3c219be66f

test result:
remove the pod marketplace-operator-XXXX in the ns openshift-marketplace, and the status 'degraded'of clusteroperator marketplace won't become "True" during the recover of the marketplace operator.

Comment 4 errata-xmlrpc 2019-10-16 06:28:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.