Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1706868 - Node detail page doesn't display node status
Summary: Node detail page doesn't display node status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 12:25 UTC by Radim Hrazdil
Modified: 2019-10-16 06:28 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Missing Node status field on the Nodes details page Consequence: User cant see the NOde's status on it's datails page Fix: Adding the status field to the detail's page Result: User can see the Node's status on it's details page
Clone Of:
Environment:
Last Closed: 2019-10-16 06:28:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:28:47 UTC

Description Radim Hrazdil 2019-05-06 12:25:01 UTC
Description of problem:
Since nodes can be switched to maintenance mode, there should be a status component in the node detail page displaying what is the current state of a node, as is the case on VM/pod detail pages.

Node state is ATM only displayed on list view (<appHost>/k8s/cluster/nodes) page.

Version-Release number of selected component (if applicable):
kubevirt-web-ui:v2.0.0-14.1

How reproducible:
100%

Steps to Reproduce:
1. Navigate to Node detail page
2.
3.

Actual results:
no information about status

Expected results:
Status icon and text information

Additional info:

Comment 1 Tomas Jelinek 2019-05-09 07:30:08 UTC
@nelly:
sorry, removing my devel ack - I have misunderstood this BZ. This is actually an RFE. The thing is that on the nodes overview page there is a "status" field and we have properly enriched it to show the "maintenance" status. 
But, the thing is that the core openshift does not contain the "status" on the node details screen. And this BZ asks for adding it there. So this is rather an RFE to enrich the core openshift functionality than fixing a gap in our implementation of the maintenance. So I'd propose to move the content of this BZ to jira and close this BZ. Do you agree?

Comment 2 Tomas Jelinek 2019-05-15 13:39:40 UTC
Since the node status is not present in the core openshift's console, moving to the proper team to decide if it is needed / prioritize.

Comment 3 Jakub Hadvig 2019-05-16 09:15:07 UTC
So we are displaying the Node status on the list page where we are determining it from the "Ready" condition type, if its true. If its not true the we set the status to "Not Ready"
I see we are missing the Status on the details page, which we should probably add.

Comment 4 Jakub Hadvig 2019-05-16 09:17:52 UTC
Fixing PR: https://github.com/openshift/console/pull/1576

Comment 5 Yadan Pei 2019-05-29 03:05:09 UTC
no OCP 4.2 builds available now, move back to MODIFIED

Comment 7 shahan 2019-06-26 04:40:31 UTC
The node detail page shows status of node now.
Veirified this bug.
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:439c96093beb009cad05594ef48cde4a4e6cc920aa3ef72015d4a36a62588b39
4.2.0-0.nightly-2019-06-23-223647

Comment 8 errata-xmlrpc 2019-10-16 06:28:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.