Bug 1706875 - python-CacheControl fails to build on rawhide/f31
Summary: python-CacheControl fails to build on rawhide/f31
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-CacheControl
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FTBFS PYTHON38 1732841
TreeView+ depends on / blocked
 
Reported: 2019-05-06 12:34 UTC by Patrik Kopkan
Modified: 2019-08-20 16:19 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-20 16:19:29 UTC
Type: Bug


Attachments (Terms of Use)
Copr build log (22.19 KB, text/plain)
2019-05-06 12:34 UTC, Patrik Kopkan
no flags Details

Description Patrik Kopkan 2019-05-06 12:34:02 UTC
Created attachment 1564418 [details]
Copr build log

python-CacheControl-0.12.5-3 seems to fail building due to missing plugin.

scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=34677419

at attachment is build log with python3.8

Comment 1 Patrik Kopkan 2019-05-06 12:43:29 UTC

*** This bug has been marked as a duplicate of bug 1675712 ***

Comment 2 Miro Hrončok 2019-07-10 11:28:34 UTC
Slávek, do you still maintain this package or should it be orphaned?

Comment 3 Ben Cotton 2019-08-13 16:50:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 4 Ben Cotton 2019-08-13 18:48:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 5 Miro Hrončok 2019-08-14 22:24:22 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 6 Fabio Valentini 2019-08-20 08:09:14 UTC
This issue is caused by an incompatibility with pytest >= 4.0.
I've applied the workaround recommended by upstream and will submit a build to f32-python shortly.

Comment 7 Fabio Valentini 2019-08-20 08:26:00 UTC
Ok, build for f32-python is blocked by the build failure of python3-cherrypy with python 3.8.
The latest commit in the python-CacheControl master branch *should* build in f32-python once cherrypy is rebuilt as well.

It's already built for f31: https://koji.fedoraproject.org/koji/buildinfo?buildID=1361214

Comment 8 Miro Hrončok 2019-08-20 08:59:09 UTC
python-cherrypy: nothing provides python(abi) = 3.7 needed by python3-portend-2.5-2.fc31.noarch

python-portend: python3-jaraco-functools, python3-jaraco-packaging, python3-tempora

python-jaraco-packaging BuildRequires  python3dist(importlib-metadata)

Comment 9 Miro Hrončok 2019-08-20 09:06:30 UTC
python-jaraco-packaging no longer BuildRequires  python3dist(importlib-metadata)


Note You need to log in before you can comment on or make changes to this bug.