Bug 170688 - rc.sysinit error on setting clock when not using LANG=en_US
rc.sysinit error on setting clock when not using LANG=en_US
Status: CLOSED DUPLICATE of bug 165222
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-13 15:28 EDT by Danilo Gimenez
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 15:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Danilo Gimenez 2005-10-13 15:28:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.7.12) Gecko/20050923 CentOS/1.0.7-1.4.1.centos4 Firefox/1.0.7

Description of problem:
When running a system on a language other then en_US, /etc/rc.d/rc.sysinit may incur on an error at the following line:

   action $"Setting clock $CLOCKDEF: `date`" date

The command `date` (enclosed by quotes) may be translated into the local language. This error may be reproduced, for instance, by installing RHEL using Brazilian Portuguese and booting up the system. On system startup, the comannd `date` will be translated from English into Portuguese (because it is enclosed by quotes), causing rc.sysinit to execute `data`. The word "data" is the Portuguese translation for the English word "date".

Once this is happening with pt_BR, this also may be occouring when using other languages, like "fr', "es" or "it".

Version-Release number of selected component (if applicable):
initscripts-7.93.13.EL

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL using a default language other than en_US (by instance, pt_BR)
2. Boot up the system
3. Observe system startup messages on console
  

Actual Results:  The rc.sysinit shows an error when executing line
   action $"Setting clock $CLOCKDEF: `date`" date

Expected Results:  The rc.sysinit should have executed the "date" command wihout issuing an error message

Additional info:
Comment 1 Bill Nottingham 2005-10-17 15:06:09 EDT

*** This bug has been marked as a duplicate of 165222 ***

Note You need to log in before you can comment on or make changes to this bug.