Bug 1706894 - OAuth server route has wrong URL
Summary: OAuth server route has wrong URL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: Mo
QA Contact: Chuan Yu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 13:04 UTC by Mo
Modified: 2019-06-04 10:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:32 UTC

Description Mo 2019-05-06 13:04:46 UTC
Description of problem:
This is a permanent API that needs to line up with the route.subdomain changes that are coming.  We can never change this URL later as it breaks OAuth callbacks and OAuth issuers can never change.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Mo 2019-05-06 13:26:23 UTC
If the fix fails to land for beta5, a beta5 to release upgrade that is using OAuth IDPs will break as the redirect URL will change.  The upgrade itself will be successful and all infra will keep working - users will not be able to log in afterwards.  The fix will be to update the redirect URL in the IDP itself.

This should not be considered a beta5 blocker.

This is a release blocker.

Comment 5 scheng 2019-05-07 13:59:58 UTC
vefified.

Comment 7 errata-xmlrpc 2019-06-04 10:48:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.