Bug 170690 - gthumb fails to import from USB camera - could not claim interface.
gthumb fails to import from USB camera - could not claim interface.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: Yellowpad
  Show dependency treegraph
 
Reported: 2005-10-13 15:31 EDT by John Ellson
Modified: 2013-03-13 00:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 08:34:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-10-13 15:31:35 EDT
Description of problem:
gthumb appears to not have permissions to access USB camera.

Camera can be read by gphoto2, but only if run as root.

Version-Release number of selected component (if applicable):
gthumb-2.6.8-2
gphoto2-2.1.6-2
hal-0.5.4-3
udev-069-10
hotplug-2004_09_23-10
kernel-2.6.13-1.1601_FC5

How reproducible:
100%

Steps to Reproduce:
1.plug in Canon PowerShot Pro1 USB cable.
2.
3.
  
Actual results:
An error occurred in the io-library ('Could not claim the USB device'): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device.

Expected results:


Additional info:
Comment 1 John Ellson 2005-10-25 13:44:07 EDT
Why is there no response from the packager, the developer, or QA on this bug? 
Not even a request for more info!

USB cameras on Fedora have been broken for months now.  If someone needs help
fixing this a good place to start migt be by responding to bugs like this with
some indication of where the problem lies.
Comment 2 John (J5) Palmieri 2005-10-25 13:53:44 EDT
Sorry, for the long wait but I have been busy with a slew of other things.  The
problem is currently being fixed but may be low in the queue.  The problem is
permissions aren't being set correctly in /proc when a camera is added.  A quick
fix would be to set the permissions of your device in /proc/bus/usb to your user
and group when you plug in the camera.  Please be patient as this will be fixed
before we release fc5 and most likely before we release test1.
Comment 3 John Ellson 2005-11-12 09:53:13 EST
Fix for this is gphoto2-1.1.6-6 + patch from Bug# 150985 comment #16
Comment 4 Matthias Clasen 2005-12-21 08:34:27 EST
So this is fixed in rawhide then, right ? If not, please reopen.
Comment 5 Dawid Zamirski 2006-03-14 18:51:07 EST
I still have this problem with my Canon EOS 300D (gphoto2-2.1.99-8,
kernel-2.6.15-1.2041_FC5).

Note You need to log in before you can comment on or make changes to this bug.