Bug 17070 - quota related system hang
Summary: quota related system hang
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-29 12:50 UTC by Juan Manuel Calvo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 01:25:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Juan Manuel Calvo 2000-08-29 12:50:30 UTC
I have found this problem with all  rh6.x versions, I don't know if it is
applicable to other
versions. My system has about 3000 active accounts.

The problem is:

The variable displayed with     

$ cat  /proc/sys/fs/dquot-nr

Increments until system hangs when this value is equal to
/proc/sys/fs/dquot-max (default 1024). A temporary workaround is increment
this value.

Rebooting the system dquot-nr returns to 0 and starts incrementing again.

Comment 1 Philip Rowlands 2000-08-30 18:08:19 UTC
This from the kernel documentation:

dquot-nr and dquot-max
   The file dquot-max shows the maximum number of cached disk quota
   entries.

   The file dquot-nr shows the number of allocated disk quota
   entries and the number of free disk quota entries.

   If the number of free cached disk quotas is very low and you have
   a large number of simultaneous system users, you might want
   to raise the limit.


Of course, it shouldn't hang when this resource gets low, but you might find
that:
echo 4096 > /proc/sys/fs/dquot-max
in /etc/rc.d/rc.local will solve your problems.

Comment 2 Preston Brown 2001-02-01 23:38:10 UTC
this is a kernel issue.  Is it still present in RH7 (2.2.16 and later) kernels?


Note You need to log in before you can comment on or make changes to this bug.