Bug 1707085 - [upgrade] the status.conditions of Ingress operator is not updated after upgrade
Summary: [upgrade] the status.conditions of Ingress operator is not updated after upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Daneyon Hansen
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-06 19:09 UTC by Daneyon Hansen
Modified: 2019-06-04 10:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:42 UTC
Github openshift cluster-ingress-operator pull 229 None None None 2019-05-06 22:57:38 UTC

Description Daneyon Hansen 2019-05-06 19:09:32 UTC
Description of problem:
The status.conditions of DNS operator is not updated after upgrade

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-03-18-200009

How reproducible:
Always

Steps to Reproduce:
1. install cluster with 4.0.0-0.nightly-2019-03-18-200009 
2. $ oc get clusteroperator ingress -o yaml
3. upgrade to 4.1.0-0.okd-2019-05-06-152942
4. $ oc get clusteroperator ingress -o yaml

Actual results:
The status.conditions is not updated and still show old timestamp.

Expected results:
The lastTransitionTime for status.conditions to be updated.


Additional info:
Similar issue to DNS Operator bug: https://bugzilla.redhat.com/show_bug.cgi?id=1690342

Comment 2 Daneyon Hansen 2019-05-06 20:29:32 UTC
PR https://github.com/openshift/cluster-ingress-operator/pull/230 submitted to fix this bug.

Comment 5 Hongan Li 2019-05-08 06:27:36 UTC
upgrade from 4.1.0-0.nightly-2019-05-07-201043 to 4.1.0-0.nightly-2019-05-07-233329, and the lastTransitionTime of `Progressing` is updated after upgrade.

### before upgrade
status:
  conditions:
  - lastTransitionTime: "2019-05-08T02:48:03Z"
    message: operand namespace exists
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-05-08T02:54:39Z"
    message: desired and current number of IngressControllers are equal
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-05-08T02:54:36Z"
    message: desired and current number of IngressControllers are equal
    status: "True"
    type: Available
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-ingress-operator
    resource: namespaces
  - group: ""
    name: openshift-ingress
    resource: namespaces
  versions:
  - name: operator
    version: 4.1.0-0.nightly-2019-05-07-201043

### post upgrade
status:
  conditions:
  - lastTransitionTime: "2019-05-08T02:48:03Z"
    message: operand namespace exists
    status: "False"
    type: Degraded
  - lastTransitionTime: "2019-05-08T05:29:12Z"
    message: desired and current number of IngressControllers are equal
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-05-08T02:54:36Z"
    message: desired and current number of IngressControllers are equal
    status: "True"
    type: Available
  extension: null
  relatedObjects:
  - group: ""
    name: openshift-ingress-operator
    resource: namespaces
  - group: ""
    name: openshift-ingress
    resource: namespaces
  versions:
  - name: operator
    version: 4.1.0-0.nightly-2019-05-07-233329

Comment 7 errata-xmlrpc 2019-06-04 10:48:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.