Bug 1707205 - Example command in "oc version --help" is using kubeclt, rather than oc
Summary: Example command in "oc version --help" is using kubeclt, rather than oc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: Liang Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-07 03:29 UTC by Liang Xia
Modified: 2019-06-04 10:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:42 UTC

Description Liang Xia 2019-05-07 03:29:29 UTC
Description of problem:
Check help info of command "oc version --help",
the example command is using kubectl, which should use oc.

Version-Release number of selected component (if applicable):
openshift-clients-4.1.0-201905050051.git.0.db7b699.el7.x86_64
$ oc version --client
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"db7b699c3", GitTreeState:"clean", BuildDate:"2019-05-05T05:01:26Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}

How reproducible:
Always

Steps to Reproduce:
1. oc version --help


Actual results:
$ oc version --help
Print the client and server version information for the current context
Usage:
  oc version [flags]
Examples:
  # Print the client and server versions for the current context
  kubectl version
......


Expected results:
We should use oc.

Comment 1 Maciej Szulik 2019-05-07 11:40:51 UTC
https://github.com/openshift/origin/pull/22790 should fix this.

Comment 2 Liang Xia 2019-05-14 02:25:59 UTC
Verified the issue has been fixed.


$ rpm -qa | grep openshift-clients
openshift-clients-4.1.0-201905121530.git.0.2d35f23.el7.x86_64



$ oc version --client
Client Version: version.Info{Major:"4", Minor:"1+", GitVersion:"v4.1.0", GitCommit:"2d35f238a", GitTreeState:"clean", BuildDate:"2019-05-12T19:46:37Z", GoVersion:"go1.11.5", Compiler:"gc", Platform:"linux/amd64"}



$ oc version --help
Print the client and server version information for the current context

Usage:
  oc version [flags]

Examples:
  # Print the client and server versions for the current context
  oc version

Options:
      --client=false: Client version only (no server required).
  -o, --output='': One of 'yaml' or 'json'.
      --short=false: Print just the version number.

Use "oc options" for a list of global command-line options (applies to all commands).

Comment 4 errata-xmlrpc 2019-06-04 10:48:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.