Bug 1707260 - virt-viewer 8 windows has no sound
Summary: virt-viewer 8 windows has no sound
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-viewer
Version: unspecified
Hardware: x86_64
OS: Windows
unspecified
medium
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-07 07:32 UTC by Dominik Csapak
Modified: 2020-05-06 09:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-06 09:42:15 UTC


Attachments (Terms of Use)

Description Dominik Csapak 2019-05-07 07:32:01 UTC
Description of problem:

virt-viewer 8.0 has no sound

Version-Release number of selected component (if applicable):
8.0

Steps to Reproduce:
1. start qemu (current master & 3.0.1) vm with spice and audio hardware, e.g. :

qemu-system-x86_64 -device 'qxl-vga,id=vga' -spice 'port=61000,disable-ticketing' -device 'virtio-serial,id=spice' -chardev 'spicevmc,id=vdagent,name=vdagent' -device 'virtserialport,chardev=vdagent,name=com.redhat.spice.0' -device 'AC97' -device 'ide-cd,bus=ide.0,unit=0,drive=drive-ide2,id=ide0,bootindex=100' -drive 'file=/tmp/Fedora-Workstation-Live-x86_64-29-1.2.iso,if=none,id=drive-ide2,media=cdrom' -m 2048 -smp sockets=1,cores=4 --enable-kvm

2. start virt-viewer 8.0 on windows and connect

Actual results:

no sound output

Expected results:

working sound

Additional info:

works with virt-viewer 5/6/7

Comment 1 Dominik Csapak 2019-05-07 08:12:55 UTC
a small update:

it seems to work when there is audio when the connection starts, but there is no sound when either:

no audio is running during connect
or
when there is about ~5-6 silence

Comment 2 aab 2019-10-29 15:28:59 UTC
I would agree there is a bug issue with virt-viewer-x64-8.0.

My environment Proxmox-ve: 6.0-2 (running kernel: 5.0.15-1-pve) as the host.
Window 7x64 guest running spice and using the code below added to my 000.conf file:

args: -device intel-hda,id=sound5,bus=pci.0,addr=0x18 -device hda-micro,id=sound5-codec0,bus=sound5.0,cad=0 -device hda-duplex,id=sound5-codec1,bus=sound5.0,cad=1

The workstation I'm using to remote connect to my guest is Windows 10x64 (1809). With virt-viewer-x64-8.0 the Windows start up sound would be audible when the guest vm started, but nothing after. I uninstalled version 8.0, downloaded and installed virt-viewer-x64-7.0. Sound is now working consistently.

My original post: https://forum.proxmox.com/threads/spice-connection-audio-problem.52830/#post-274348

Comment 3 WM 2019-11-16 12:03:01 UTC
I have the same audio problem with proxmox - virt-viewer setup

1st time starting an audio source it is OK. Stopping audio source and starting it the 2nd time there is no audio.

Setup proxmox 6.0-11 , virt viewer 8.0-256.

I tried all options for sound devices : intel-hda, ich9-intel-hda, AC97  all give the same problem.
Same problem with both W10 VM and Linux Mint VM

Proxmox server has no audio device itself.

Comment 4 Allen Smith 2019-12-25 00:30:01 UTC
This also happens to me under virt-viewer-8.0-3.fc31.x86_64.

No sound. The viewer build into virt-manager does have sound with the same VM.

Thanks,
-Allen

Comment 5 Allen Smith 2019-12-25 03:22:46 UTC
(In reply to Allen Smith from comment #4)
> This also happens to me under virt-viewer-8.0-3.fc31.x86_64.
> 
> No sound. The viewer build into virt-manager does have sound with the same
> VM.
> 
> Thanks,
> -Allen

I was able to get this working by doing something like:

virt-viewer -c qemu:///system win10

when my user is in libvirt group, so just perm/user error in my case.

Comment 6 CCWNC.DEVELOPER 2020-01-20 18:04:57 UTC
I had the problem with ProxMox: neither my Kubuntu, nor my Windows 7 VM had sound with v8 of virt-viewer.
When I uninstalled v8, and installed v7 (per suggestions at this site: https://forum.proxmox.com/threads/spice-connection-audio-problem.52830/) I then had sound for both VMs

Comment 7 Mike Boiko 2020-02-12 03:32:44 UTC
Yes, I had the same problem where the sound would only play the first time. I'm remoting in from Windows 10 to an Arch Linux guest.
I downgraded from virt-viewer 8.0-256 to 7.0-256 and the problem was fixed.
Hopefully, this gets fixed soon. Thanks!

Comment 8 BIDOU 2020-03-28 06:33:59 UTC
I have the exact same problem.
I found a way arround it.
First I use teh VM without the sound to the point were I need the sound. I make sure the sound is playing, then I close remote viewer.
And when I reconnect to the VM the sound is playing and keeps playing. If the sound stop (end of a music or exemple) I can't get it back.

Comment 9 Daniel Berrangé 2020-05-06 09:42:15 UTC
Closing this bug, since we're going to continue the discussion in the new upstream issue tracker at: https://gitlab.com/virt-viewer/virt-viewer/-/issues/2


Note You need to log in before you can comment on or make changes to this bug.