Bug 1707270 - Include console=tty0,115200n8 as kernel default parameter
Summary: Include console=tty0,115200n8 as kernel default parameter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Yu Qi Zhang
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-07 07:43 UTC by David Sanz
Modified: 2019-06-04 10:48 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:41 UTC

Description David Sanz 2019-05-07 07:43:50 UTC
Description of problem:
When installing OCP4.1 on Baremetal, console stops logging on "Probing EDD(edd=off to disable)... ok" and we cannot see the rest of the log.

If host doesn't start  correctly, we need to reboot it and manually add it, losing the information of the first boot.

QE debugging is being harder without that parameter as default.

Version-Release number of selected component (if applicable):

OCP4.1 based on any RHCOS8 version

How reproducible:


Steps to Reproduce:
1.Start any installation of OCP4.1
2.Look at the virtual console of the host during the booting process
3.

Actual results:
Console information stops on "Probing EDD(edd=off to disable)... ok", no information about network asignation or ignition process is showed

Expected results:
All log is showed by default

Additional info:

Comment 2 Steve Milner 2019-05-07 13:21:24 UTC
David,

Can you provide what version of the bare metal artifact you saw this in? Micah looked at a recent build and found the requested change already present.

Comment 3 Jonathan Lebon 2019-05-07 13:33:57 UTC
This should have already been fixed by https://github.com/coreos/coreos-assembler/pull/485.

Comment 4 David Sanz 2019-05-07 13:34:45 UTC
Sorry Steve,

Subject is wrong, we need console=tty0,115200n8, not just console=ttyS0,115200n8

Baremetal servers uses tty0 on the virtual console from KVM or iDRac.

My fault, I have updated the subject

Comment 5 Yu Qi Zhang 2019-05-07 13:48:17 UTC
I can confirm that I only see `console=ttys0,115200n8` in 410.8.20190506.1 from ART (the one David was reporting on)

Checking why that is the case

Comment 6 Yu Qi Zhang 2019-05-07 14:02:16 UTC
Ok it turns out ART is using a very old COSA (From Apr. 4). Should be an easy fix

Comment 17 errata-xmlrpc 2019-06-04 10:48:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.