This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 170733 - libselinux must restart init after upgrade
libselinux must restart init after upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libselinux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 04:58 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 08:56:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2005-10-14 04:58:14 EDT
Description of problem:
When upgrading libselinux the system will complain about being unable to remount
/ readonly during the next reboot. There seems to be several packages that cause
this, libselinux is one of them. I tracked this down to init, which links
against libselinux and thus holds on to the deleted old version. Since init is
not killed during shutdown the old lib is never really freed, so / can not be
umounted cleanly.
Sending a "telinit U" during libselinux %post ought to take care of this.

Version-Release number of selected component (if applicable):
libselinux-1.27.7-1

How reproducible:
Always

Steps to Reproduce:
1. Reboot
2. Upgrade (or downgrade, does not matter) libselinux
3. Reboot
  
Actual results:
/ can not be remounted ro immediately before the reboot, causing a journal
replay on the next boot

Expected results:
Clean reboot

Additional info:
Comment 1 Ralf Ertzinger 2005-11-28 08:56:55 EST
Fixed in RH

Note You need to log in before you can comment on or make changes to this bug.