Bug 170734 - An updated iputils package stops bonding of ethernet interfaces
An updated iputils package stops bonding of ethernet interfaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iputils (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
: Regression
Depends On: 163248
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 05:09 EDT by Ivan Stoykov
Modified: 2010-10-21 23:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 14:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Stoykov 2005-10-14 05:09:45 EDT
Description of problem:
After update of iputils bonding interface can't enslave ethernet interfaces.

Version-Release number of selected component (if applicable):
 kernel - 2.4.21-32.0.1.EL
 Platform - Dell PowerEdge 2850 
 ethernet driver - e1000
 regarding to ERRATA RHBA-2005:624 update from iputils-20020927-11.30.1 to
iputils-20020927-11.30.2

How reproducible:


Steps to Reproduce:
1.Install clean RHEL3-U5
2.Prepare eth0 and eth1 as SLAVE devices for bond0
3.Try new configuration
4.Update to iputils-20020927-11.30.2
5.service network stop 
6.modprobe -r e1000;modprobe -r bonding
7.service network start
8.( 5-7 can be replaced with simple reboot :)

Actual results:
bond0 doesn't enslave eth0 and eth1. ifconfig shows HWaddr 00:00:00:00:00:00 for
bond0.

Expected results:
 Interface bond0 to be up and its HWaddr to be the MAC address of 1st enslaved
device.

Additional info:
 Problem stops with rollback to iputils-20020927-11.30.1.
 Interfcae bond0 is used as "master" interface for 2 VLANs
 Because of production state of server and short time for resolving of problem I
can't reproduce situation now and send kernel and userspace error messages, sorry!
Comment 1 Radek Vokal 2005-11-08 07:09:40 EST
A testing package which fixies this issue is avaliable here

http://people.redhat.com/rvokal/iputils/20020927-11.30.3/

This bug fix is considered for next update
Comment 2 Stijn Jonker 2005-11-09 01:34:20 EST
Hello,

I can confirm this version of iputils fixes the bonding/vlan issue.

My setup:
2 x intel e1000
1 x bonding bond0
2 x vlan interfaces bond0.175/bond0.250

Both iputils-20020927-11.30.1 & iputils-20020927-11.30.3 work,
iputils-20020927-11.30.2.i386.rpm doesn't.

You mention next update, is that the periodic update or is it expected as errate
in between?

Thanks,
Stijn
Comment 8 Ivan Stoykov 2006-11-19 09:15:11 EST
It seams it is resolved already , at least - after RHBA-2006:0029

Note You need to log in before you can comment on or make changes to this bug.