Bug 1707427 - Document that kubectl drain and oc adm drain do not behave as expected
Summary: Document that kubectl drain and oc adm drain do not behave as expected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: Documentation
Version: 2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 2.0
Assignee: Pan Ousley
QA Contact: Irina Gulina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-07 13:55 UTC by Fabian Deutsch
Modified: 2020-07-27 20:36 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-24 14:53:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Fabian Deutsch 2019-05-07 13:55:05 UTC
We need a documentation item which describes how CNV behaves with oc adm drain (kubectl drain).

The problem is as follows:
Today CNV (kubevirt) can not reliably identify node drains if they are triggered through a call of "oc adm drain" (or "kubectl drain").
If these commands are called on a node of a cluster with CNV deployed, then those nodes might not go to maintenance if there are VMs running on top of that node.

Workaround:
The current solution is to use the Node Maintenance Operator for putting nodes into maintenance.

Comment 2 Pan Ousley 2019-06-09 19:23:32 UTC
Fabian, could you please provide the original BZ URL for this issue? Thanks!

Comment 3 Fabian Deutsch 2019-06-11 12:46:08 UTC
There was no original bug.

ROman/rmohrRoan can provide the relevant details for this item.

Comment 15 Pan Ousley 2019-09-24 14:53:16 UTC
The content associated with this bug was published in the CNV 2.0 Release Notes: https://docs.openshift.com/container-platform/4.1/cnv/cnv_release_notes/cnv-release-notes.html

Comment 17 Israel Pinto 2019-10-23 14:40:09 UTC
@Pan,
I verify with Dev, the issue should also be in 2.1 release notes.


Note You need to log in before you can comment on or make changes to this bug.