Bug 1707460 - Error when deploying TripleO with an external ceph cluster
Summary: Error when deploying TripleO with an external ceph cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1594251
TreeView+ depends on / blocked
 
Reported: 2019-05-07 15:06 UTC by Alan Bishop
Modified: 2020-01-31 12:46 UTC (History)
11 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc6.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3943 0 None closed facts: fix external cluster bug 2021-02-11 18:33:52 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:51 UTC

Description Alan Bishop 2019-05-07 15:06:20 UTC
Description of problem:

I'm doing a standalone TripleO deployment on upstream master, with it configured to connect to an existing ceph cluster. This uses TripleO's [1] heat template.

The ceph-ansible portion of the deployment fails with the following error:

2019-05-06 21:18:01,675 p=37682 u=root |  TASK [ceph-facts : set_fact _monitor_address to monitor_address_block ipv4] ****
2019-05-06 21:18:01,675 p=37682 u=root |  task path: /usr/share/ceph-ansible/roles/ceph-facts/tasks/set_monitor_address.yml:2
2019-05-06 21:18:01,675 p=37682 u=root |  Monday 06 May 2019  21:18:01 +0000 (0:00:00.079)       0:00:11.421 ************
2019-05-06 21:18:01,756 p=37682 u=root |  TASK [ceph-facts : set_fact _monitor_address to monitor_address_block ipv6] ****
2019-05-06 21:18:01,756 p=37682 u=root |  task path: /usr/share/ceph-ansible/roles/ceph-facts/tasks/set_monitor_address.yml:13
2019-05-06 21:18:01,757 p=37682 u=root |  Monday 06 May 2019  21:18:01 +0000 (0:00:00.081)       0:00:11.502 ************
2019-05-06 21:18:01,846 p=37682 u=root |  TASK [ceph-facts : set_fact _monitor_address to monitor_address] ***************
2019-05-06 21:18:01,846 p=37682 u=root |  task path: /usr/share/ceph-ansible/roles/ceph-facts/tasks/set_monitor_address.yml:24
2019-05-06 21:18:01,847 p=37682 u=root |  Monday 06 May 2019  21:18:01 +0000 (0:00:00.090)       0:00:11.592 ************
2019-05-06 21:18:01,921 p=37682 u=root |  TASK [ceph-facts : set_fact _monitor_address to monitor_interface - ipv4] ******
2019-05-06 21:18:01,922 p=37682 u=root |  task path: /usr/share/ceph-ansible/roles/ceph-facts/tasks/set_monitor_address.yml:34
2019-05-06 21:18:01,922 p=37682 u=root |  Monday 06 May 2019  21:18:01 +0000 (0:00:00.075)       0:00:11.668 ************
2019-05-06 21:18:01,996 p=37682 u=root |  TASK [ceph-facts : set_fact _monitor_address to monitor_interface - ipv6] ******
2019-05-06 21:18:01,996 p=37682 u=root |  task path: /usr/share/ceph-ansible/roles/ceph-facts/tasks/set_monitor_address.yml:46
2019-05-06 21:18:01,997 p=37682 u=root |  Monday 06 May 2019  21:18:01 +0000 (0:00:00.074)       0:00:11.742 ************
2019-05-06 21:18:02,070 p=37682 u=root |  TASK [ceph-facts : set_fact _current_monitor_address] **************************
2019-05-06 21:18:02,070 p=37682 u=root |  task path: /usr/share/ceph-ansible/roles/ceph-facts/tasks/set_monitor_address.yml:58
2019-05-06 21:18:02,070 p=37682 u=root |  Monday 06 May 2019  21:18:02 +0000 (0:00:00.073)       0:00:11.816 ************
2019-05-06 21:18:02,106 p=37682 u=root |  fatal: [node-1]: FAILED! =>
  msg: '''_monitor_addresses'' is undefined'



[1] https://github.com/openstack/tripleo-heat-templates/blob/master/environments/ceph-ansible/ceph-ansible-external.yaml

Version-Release number of selected component (if applicable):

ceph-ansible-4.0.0-0.rc5.1.el7.noarch

How reproducible:

Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Yogev Rabl 2019-06-04 13:31:01 UTC
Verified on ceph-ansible-4.0.0-0.1.rc6.el8cp

Comment 4 Donny Davis 2019-06-27 19:01:54 UTC
Confirmed for 	ceph-ansible-4.0.0-0.rc4.1.el7.noarch.rpm and 	ceph-ansible-4.0.0-0.rc3.1.el7.noarch.rpm

Comment 6 errata-xmlrpc 2020-01-31 12:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.