Bug 1707479 - workers are not created when pool default path other than "/var/lib/libvirt/images"
Summary: workers are not created when pool default path other than "/var/lib/libvirt/i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Zeeshan Ali
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-07 15:25 UTC by Asher Shoshan
Modified: 2020-04-08 16:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Installer assumed a specific path where images go. Consequence: Thing break if that assumption is not valid Fix: Installer now creates & uses it's own storage pool. Result: Same as Fix.
Clone Of:
Environment:
Last Closed: 2019-10-16 06:28:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:28:43 UTC

Description Asher Shoshan 2019-05-07 15:25:49 UTC
Description of problem:
Due to space issues, after changing the path of pool default (i.e. pool-edit, pool-destroy, pool-start), workers are not created at all.
 
Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1. Change path in pool default
2. Run installer (master + workers in config.yaml)

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated
No error msg appeared

Expected results:
Same behavior as with the default path "/var/lib/libvirt/images"

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Zeeshan Ali 2019-06-18 16:20:17 UTC
I believe I already fixed this with: https://github.com/openshift/installer/pull/1628

Comment 3 weiwei jiang 2019-07-01 12:10:30 UTC
Checked and work well now.

$ bin/openshift-install version
bin/openshift-install unreleased-master-1205-g59dd3e5b94349ec0b42690c13a688a6a4e5f8d81
built from commit 59dd3e5b94349ec0b42690c13a688a6a4e5f8d81
release image registry.svc.ci.openshift.org/origin/release:4.2

virsh # vol-list default
 Name                                   Path
----------------------------------------------------------------------------------------------------------
 wjiang-w72vx-base                      /var/lib/libvirt/images.new/wjiang-w72vx-base
 wjiang-w72vx-bootstrap                 /var/lib/libvirt/images.new/wjiang-w72vx-bootstrap
 wjiang-w72vx-bootstrap.ign             /var/lib/libvirt/images.new/wjiang-w72vx-bootstrap.ign
 wjiang-w72vx-master-0                  /var/lib/libvirt/images.new/wjiang-w72vx-master-0
 wjiang-w72vx-master.ign                /var/lib/libvirt/images.new/wjiang-w72vx-master.ign
 wjiang-w72vx-worker-0-hmmlm            /var/lib/libvirt/images.new/wjiang-w72vx-worker-0-hmmlm
 wjiang-w72vx-worker-0-hmmlm.ignition   /var/lib/libvirt/images.new/wjiang-w72vx-worker-0-hmmlm.ignition

virsh # list
 Id   Name                          State
---------------------------------------------
 1    wjiang-w72vx-bootstrap        running
 2    wjiang-w72vx-master-0         running
 3    wjiang-w72vx-worker-0-hmmlm   running

Comment 4 errata-xmlrpc 2019-10-16 06:28:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.