Bug 170753 - yum leaves old rpms installed on first update
yum leaves old rpms installed on first update
Status: CLOSED DUPLICATE of bug 161038
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-14 09:11 EDT by Pedro Bezunartea
Modified: 2014-01-21 17:52 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:12:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Bezunartea 2005-10-14 09:11:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); es-ES; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Packages are duplicated with different versions and architectures. In many I have 4 installed: old version (i386 and x86_64), and updated version (i386 and x86_64).


Version-Release number of selected component (if applicable):
yum-2.4.0-0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4 on a x86_64 system.
2. yum update
3. Check packages with: rpm -qa  --qf "%{N}-%{V}-%{R}.%{ARCH}\n"

  

Actual Results:  Many packages have i386 and x86_64 versions installed (i don't know if this is on purpose) and two versions, eg:
arts-1.4.0-1.i386
arts-1.4.0-1.x86_64
arts-1.4.2-0.fc4.1.i386
arts-1.4.2-0.fc4.1.x86_64


Expected Results:  Only one package, x86_64 architecture.

Additional info:

I can attach the package list if needed.
Comment 1 Andre Robatino 2005-10-14 14:24:05 EDT
  This appears related to bug #161038 where the same thing happens with up2date.
Comment 2 Seth Vidal 2005-11-07 00:56:36 EST
On this first run - did you yum hang or exit abnormally?
Comment 3 Pedro Bezunartea 2005-11-07 06:47:34 EST
Nope. Yum appeared to work fine, it didn't complain, give any errors or warnings.
Comment 4 Andre Robatino 2005-12-10 13:43:57 EST
  See also bug #175431.
Comment 5 Jeremy Katz 2006-04-19 16:12:47 EDT

*** This bug has been marked as a duplicate of 161038 ***
Comment 6 Andre Robatino 2006-04-19 16:24:40 EDT
  NOT SO FAST!  This bug was closed as a duplicate of bug #161038, but then
161038 was closed because it pertained to up2date which is gone.  Yum is NOT
gone, however, so please don't close this very serious and currently existing
bug!  In fact, it would make more sense to mark 161038 as a duplicate of this
bug since some of the discussion there is still relevant.

Note You need to log in before you can comment on or make changes to this bug.