Bug 1707814 - check_icmp performance data output changed
Summary: check_icmp performance data output changed
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios-plugins
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen John Smoogen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-08 12:59 UTC by vlado.bilik@gmail.com
Modified: 2019-09-26 13:28 UTC (History)
8 users (show)

Fixed In Version: nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 nagios-plugins-2.2.1-17.20190829gitfb792ff.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-14 00:40:38 UTC
Type: Bug


Attachments (Terms of Use)

Description vlado.bilik@gmail.com 2019-05-08 12:59:15 UTC
Description of problem:
Previous release (2.2.1-4git.el7.x86_64) of check_icmp produces performance data in order rta/pl/rtmax/rtmin, i.e.:
rta=1.845ms;3000.000;5000.000;0; pl=0%;80;99;; rtmax=2.052ms;;;; rtmin=1.726ms;;;;

Latest release (2.2.1-16.20180725git3429dad.el7.x86_64) changed the order of data to rta/rtmax/rtmin/pl, i.e:
rta=1.845ms;3000.000;5000.000;0; rtmax=2.052ms;;;; rtmin=1.726ms;;;; pl=0%;80;99;;

This confuse the graphing software which handles the data and relies on given order of the data.


Version-Release number of selected component (if applicable):
2.2.1-16.20180725git3429dad.el7.x86_64

How reproducible:
/usr/lib64/nagios/plugins/check_icmp google.com
OK - google.com rta 13.350ms lost 0%|rta=13.350ms;200.000;500.000;0; rtmax=13.459ms;;;; rtmin=13.248ms;;;; pl=0%;40;80;0;100

Actual results:
rta=13.350ms;200.000;500.000;0; rtmax=13.459ms;;;; rtmin=13.248ms;;;; pl=0%;40;80;0;100

Expected results:
rta=13.350ms;200.000;500.000;0; pl=0%;40;80;0;100 rtmax=13.459ms;;;; rtmin=13.248ms;;;; 

Additional info:

Comment 1 Stephen John Smoogen 2019-05-08 13:54:37 UTC
This would normally be an upstream bug at https://github.com/nagios-plugins but that hasn't seen an update/fix since 2017 in main and mid 2018 in maintenance. 

The cause of the change is hard to find because they did a major reformatting which makes git blame say everything was due to one change. It looks like they reordered in 2016 for some reason.

Comment 2 Fedora Update System 2019-08-29 21:51:16 UTC
FEDORA-EPEL-2019-9b63c08c0f has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9b63c08c0f

Comment 3 Fedora Update System 2019-08-29 22:04:13 UTC
FEDORA-EPEL-2019-22c97df420 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-22c97df420

Comment 4 Fedora Update System 2019-08-30 16:07:43 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-22c97df420

Comment 5 Fedora Update System 2019-08-30 16:07:45 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9b63c08c0f

Comment 6 Fedora Update System 2019-09-14 00:40:38 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-09-14 04:05:16 UTC
nagios-plugins-2.2.1-17.20190829gitfb792ff.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Cristian Seres 2019-09-26 09:49:48 UTC
Hi,
the problem seems to persist (tested with CentOS 6.10 i686):

-sh-4.1$ rpm -qf /usr/lib/nagios/plugins/check_icmp
nagios-plugins-icmp-2.2.1-17.20190829gitfb792ff.el6.i686

-sh-4.1$ /usr/lib/nagios/plugins/check_icmp google.com
OK - google.com rta 12.951ms lost 0%|rta=12.951ms;200.000;500.000;0; rtmax=13.093ms;;;; rtmin=12.883ms;;;; pl=0%;40;80;0;100 
-sh-4.1$

Comment 9 Stephen John Smoogen 2019-09-26 13:28:01 UTC
OK I think this might be something that upstream has decided is what they want. I don't have the ability to patch back to the old way of doing things. I am going to change this to CANTFIX and my apologies. I suggest that you open an issue with the upstream and see if they will give an option to go back to the old way.


Note You need to log in before you can comment on or make changes to this bug.