Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1707905 - After upgrading ingresses.spec.domain,the host of route will be upgraded automatically
Summary: After upgrading ingresses.spec.domain,the host of route will be upgraded auto...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.3.0
Assignee: Matt Rogers
QA Contact: scheng
URL:
Whiteboard:
: 1727870 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-08 16:37 UTC by scheng
Modified: 2020-01-23 11:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: route to oauth-server did not react to ingress domain changes Consequence: authentication operator goes degraded when default ingress domain changes, oauth-server will be unreachable and authentication would not work Fix: update the route on ingress domain change Result: authentication works even after the domain changed
Clone Of:
Environment:
Last Closed: 2020-01-23 11:03:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-authentication-operator pull 176 0 None closed Bug 1707905: Update route when ingress domain changes 2020-03-24 08:47:41 UTC
Github openshift cluster-authentication-operator pull 184 0 None closed Bug 1740366: Add strict validation for router certs 2020-03-24 08:47:41 UTC
Red Hat Product Errata RHBA-2020:0062 0 None None None 2020-01-23 11:03:57 UTC

Description scheng 2019-05-08 16:37:25 UTC
When ingresses.spec.domain is upgraded,,the host field of authentication route will be upgraded automatically.

Comment 2 Mo 2019-07-10 14:37:27 UTC
*** Bug 1727870 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2020-01-23 11:03:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.