Bug 1708056 - Unable to use "GTK+ Window Decorator" on compiz, window title disappears
Summary: Unable to use "GTK+ Window Decorator" on compiz, window title disappears
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-09 05:20 UTC by Daniel
Modified: 2019-05-21 02:20 UTC (History)
4 users (show)

Fixed In Version: compiz-0.8.16.1-1.fc29.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-21 02:20:15 UTC


Attachments (Terms of Use)

Description Daniel 2019-05-09 05:20:06 UTC
Description of problem:
Unable to use "GTK+ Window Decorator" on compiz, windows title disappears.

Version-Release number of selected component (if applicable):
$ rpm -q compiz
compiz-0.8.16.1-1.fc29.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. Login in to MATE Desktop with compiz.
2. Select "GTK+ Window Decorator" from Fusion Icon's "Select Window Decorator" menu.


Actual results:
Window title disappeared.

Expected results:
Window title should be shown.

Additional info:
Here is the result of command "gtk-window-decorator --replace" in terminal.
$ gtk-window-decorator --replace
Bug in window manager: Could not find a button to strip. n_left = 9 n_right = 7
Aborted (core dumped)

Comment 1 Jaroslav Škarvada 2019-05-09 08:40:54 UTC
It's working for me:
$ gtk-window-decorator --replace

(gtk-window-decorator:6138): Gtk-WARNING **: 10:38:55.846: Theme parsing error: gtk.css:6:20: The 'gtk-key-bindings' property has been renamed to '-gtk-key-bindings'
Varování správce oken: Nelze načíst motiv "Menta": Nelze nalézt platný soubor motivu Menta

And the decoration works, i.e. changed from the the emerald theme and nothing crashed.

Could you try with clean config? E.g. under the newly created user. If it still crashes, please bring the problem upstream.

Comment 2 lists 2019-05-09 09:42:00 UTC
I am also experiencing the same problem as the original poster. My setup is:

Mate + Compiz spin
All current errata
5.0.11-200.fc29.x86_64

Could this be related to the recent MATE upgrade to 1.22?

Comment 3 Daniel 2019-05-09 10:06:29 UTC
(In reply to Jaroslav Škarvada from comment #1)
> It's working for me:
> $ gtk-window-decorator --replace
> 
> (gtk-window-decorator:6138): Gtk-WARNING **: 10:38:55.846: Theme parsing
> error: gtk.css:6:20: The 'gtk-key-bindings' property has been renamed to
> '-gtk-key-bindings'
> Varování správce oken: Nelze načíst motiv "Menta": Nelze nalézt platný
> soubor motivu Menta
> 
> And the decoration works, i.e. changed from the the emerald theme and
> nothing crashed.
> 
> Could you try with clean config? E.g. under the newly created user. If it
> still crashes, please bring the problem upstream.

Thank you very much for your contact.
I created a new user and the bug still exists when I login which the new user.

Comment 4 Jaroslav Škarvada 2019-05-10 05:23:49 UTC
On f30 it seems to work. I provisioned new machine with the MATE spin (f30 x86_64) with the latest updates, then:
$ fusion-icon 
 * Detected Session: mate
 * Searching for installed applications...
 * Using the GTK+ Interface
 * Decorator "compiz-decorator --replace" is invalid.
 * Setting decorator to GTK+ Window Decorator ("gtk-window-decorator --replace")
 * Starting Compiz
 ... executing: compiz ccp --replace --sm-disable --ignore-desktop-hints

And everything seems working as expected.
compiz-0.8.16.1-1.fc30.x86_64

I am going to check the f29 spin now (I provisioned f30 by an mistake :)

Comment 5 lists 2019-05-10 10:41:02 UTC
My testing also confirms that f30 is unaffected. Seems it's just f29.

Comment 6 Jaroslav Škarvada 2019-05-10 16:31:21 UTC
(In reply to Jaroslav Škarvada from comment #4)
> On f30 it seems to work. I provisioned new machine with the MATE spin (f30
> x86_64) with the latest updates, then:
> $ fusion-icon 
>  * Detected Session: mate
>  * Searching for installed applications...
>  * Using the GTK+ Interface
>  * Decorator "compiz-decorator --replace" is invalid.
>  * Setting decorator to GTK+ Window Decorator ("gtk-window-decorator
> --replace")
>  * Starting Compiz
>  ... executing: compiz ccp --replace --sm-disable --ignore-desktop-hints
> 
> And everything seems working as expected.
> compiz-0.8.16.1-1.fc30.x86_64
> 
> I am going to check the f29 spin now (I provisioned f30 by an mistake :)

The compiz-0.8.14-6.fc29.x86_64 seems to work, trying to upgrade.

Comment 7 Jaroslav Škarvada 2019-05-10 22:40:37 UTC
I was finally able to upgrade it. It seems the problem is in the MATE - it works OK under XFCE in f29. The problem is probably in the marco-libs. I will investigate more deep.

Comment 8 Jaroslav Škarvada 2019-05-10 22:58:49 UTC
(In reply to Jaroslav Škarvada from comment #7)
> I was finally able to upgrade it. It seems the problem is in the MATE - it
> works OK under XFCE in f29. The problem is probably in the marco-libs. I
> will investigate more deep.

It crashes in the marco-libs, but the marco-libs seems to be the same version in the f29-30.

Comment 9 Jaroslav Škarvada 2019-05-10 23:04:19 UTC
It seems that just compiz recompile does the trick :)

Comment 10 Jaroslav Škarvada 2019-05-10 23:16:16 UTC
The source of the problem is that compiz was compiled against marco-devel-1.20.3-1.fc29, but in the meantime while the compiz was in the updates-testing, marco has been updated to the marco-devel-1.22.1-1.fc29 and broke the ABI. As a compiz maintainer I am afraid I am unable to notice such changes - ABI of libs should stay stable during the release. If there is incompatible ABI change, the SONAME of the library should be changed.

Comment 11 Fedora Update System 2019-05-10 23:31:01 UTC
compiz-0.8.16.1-1.fc29.1 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-837f07eda4

Comment 12 Fedora Update System 2019-05-11 04:24:17 UTC
compiz-0.8.16.1-1.fc29.1 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-837f07eda4

Comment 13 lists 2019-05-11 10:07:12 UTC
That's fixed the problem for me. Excellent work Jaroslav, thanks!

Comment 14 Daniel 2019-05-13 03:45:57 UTC
That fixed the problem for me, also.
Thanks a lot.

Comment 15 Fedora Update System 2019-05-21 02:20:15 UTC
compiz-0.8.16.1-1.fc29.1 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.