Bug 1708058 - io-threads xlator doesn't scale threads in some situations
Summary: io-threads xlator doesn't scale threads in some situations
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: io-threads
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-09 05:29 UTC by Pranith Kumar K
Modified: 2020-03-12 14:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-12 14:48:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 22686 0 None Abandoned performance/io-threads: Scale threads to match number of fops 2019-10-03 19:31:41 UTC

Description Pranith Kumar K 2019-05-09 05:29:49 UTC
Description of problem:

I was working on a .t where two requests are wound one after the other, the first fop that is wound takes more than a second(because of delay-gen) and the next doesn't. This was leading to both the fops taking delay-duration seconds instead of second fop unwinding earlier than the first one. When I debugged it, I found that io-threads is not matching threads to number of fops even when it can. The .t that I am working on for another bz will be updated at https://review.gluster.org/c/glusterfs/+/22674

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2019-05-09 05:31:57 UTC
REVIEW: https://review.gluster.org/22686 (performance/io-threads: Scale threads to match number of fops) posted (#2) for review on master by Pranith Kumar Karampuri

Comment 2 Worker Ant 2020-03-12 14:48:24 UTC
This bug is moved to https://github.com/gluster/glusterfs/issues/1065, and will be tracked there from now on. Visit GitHub issues URL for further details


Note You need to log in before you can comment on or make changes to this bug.