Bug 1708069 - Curator pod in Error status: pkg_resources.DistributionNotFound: elasticsearch>=5.4.0,<6.0.0
Summary: Curator pod in Error status: pkg_resources.DistributionNotFound: elasticsearc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.1.0
Assignee: Rich Megginson
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-09 05:55 UTC by Qiaoling Tang
Modified: 2019-06-04 10:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:47 UTC

Description Qiaoling Tang 2019-05-09 05:55:04 UTC
Description of problem:
The curator always in Error status, no indices will be deleted, curator pod logs:
$ oc logs curator-1557378900-7wk8m
2019-05-09 05:15:17,357 INFO	Found curator configuration in [/etc/curator/settings/config.yaml]
2019-05-09 05:15:17,363 INFO	Converting config file.
Traceback (most recent call last):
  File "/usr/bin/curator", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3007, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 728, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: elasticsearch>=5.4.0,<6.0.0


Version-Release number of selected component (if applicable):
ose-logging-curator5:v4.1.0-201905082141


How reproducible:
Always

Steps to Reproduce:
1.Deploy logging using downstream images
2.set curator cronjob schedule to `*/5 * * * *`, wait for a while, check curator pod status
3.

Actual results:


Expected results:


Additional info:
Also tested using upstream image(quay.io/openshift/origin-logging-curator5@sha256:4d7a56d09666abdd606c737c6d79b011cab7c8608ab9aa569d8f5e67a0afa413), doesn't have this issue.

Comment 3 Anping Li 2019-05-09 10:20:01 UTC
Copy Josef  comment from slack here.
package `python-elasticsearch-5.5.5-2.el7` in `rhel-7-server-ose-4.1-rpms` installs the same files twice, which makes resolution problems.
package `python-elasticsearch-5.4.0-1.el7` from `rhel-7-server-ose-3.11-rpms` installs correctly

Comment 9 Anping Li 2019-05-13 05:17:22 UTC
Verified in openshift/ose-logging-curator5:v4.1.0-201905121530

Comment 11 errata-xmlrpc 2019-06-04 10:48:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.