Bug 1708096 - playbook is failing for task: ceph-mgr installation
Summary: playbook is failing for task: ceph-mgr installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Build
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Ken Dreyer (Red Hat)
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-09 07:14 UTC by Uday kurundwade
Modified: 2020-01-31 12:46 UTC (History)
10 users (show)

Fixed In Version: ceph-mgr-dashboard-14.2.1-124.g35e6f59.el8cp ceph-mgr-diskprediction-local-14.2.1-124.g35e6f59.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:51 UTC

Description Uday kurundwade 2019-05-09 07:14:17 UTC
Description of problem:
playbook is failing for TASK [ceph-mgr : install ceph-mgr packages on RedHat or SUSE]

Version-Release number of selected component (if applicable):
ceph-ansible-4.0.0-0.1.rc5.el8cp.noarch
ansible-2.8.0-0.8.rc1.el8ae.noarch

How reproducible:
Always

Steps to Reproduce:
1.add ceph mgr nodes in inventory file
2.Run the playbook.
3.

Actual results:
TASK [ceph-mgr : install ceph-mgr packages on RedHat or SUSE] ********************************************************************************************************************************
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (3 retries left).
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (2 retries left).
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (1 retries left).
fatal: [machine_name]: FAILED! => changed=false 
  attempts: 3
  failures:
  - No package ceph-mgr-dashboard available.
  - No package ceph-mgr-diskprediction-local available.
  msg:
  - Failed to install some of the specified packages
  rc: 1
  results: []

Expected results:
Playbook should run successfully.

Additional info:

Comment 3 rakesh 2019-05-27 17:01:36 UTC
Hi Ken, 

Any update on this. we wanted to start testing on ceph 4.0 builds. This is blocking.

Comment 10 errata-xmlrpc 2020-01-31 12:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.