Bug 1708274 - python3-qt5 requires libpython2.7.so.1.0
Summary: python3-qt5 requires libpython2.7.so.1.0
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-qt5
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON3-PYTHON2
TreeView+ depends on / blocked
 
Reported: 2019-05-09 14:00 UTC by Miro Hrončok
Modified: 2019-07-08 07:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-07 23:00:25 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-05-09 14:00:20 UTC
python3-qt5 requires libpython2.7.so.1.0. It seems that the extensions installed into /usr/lib64/python3.7/site-packages/ are built against Python 2.

$ dnf repoquery --repo=compose python3-qt5 
python3-qt5-0:5.12.2-1.fc31.i686
python3-qt5-0:5.12.2-1.fc31.x86_64


$ dnf repoquery --repo=compose --requires python3-qt5 | grep python
libpython2.7.so.1.0
libpython2.7.so.1.0()(64bit)
python(abi) = 3.7
python3-qt5-base(x86-32) = 5.12.2-1.fc31
python3-qt5-base(x86-64) = 5.12.2-1.fc31

Comment 1 Raphael Groner 2019-05-10 18:59:08 UTC
Not reproducible in F30.

Since when do we have a repo named compose? Is that official?

Comment 2 Miro Hrončok 2019-05-10 19:28:49 UTC
The compose repo is:

[compose]
name=Rawhide Compose
baseurl=https://kojipkgs.fedoraproject.org/compose/rawhide/latest-Fedora-Rawhide/compose/Everything/$basearch/os/
skip_if_unavailable=False
enabled=0

[compose-source]
name=Rawhide Compose Source
baseurl=https://kojipkgs.fedoraproject.org/compose/rawhide/latest-Fedora-Rawhide/compose/Everything/source/tree/
skip_if_unavailable=False
enabled=0

I only use it to get faster rawhide. But rawhide has this as well:

$ dnf repoquery --repo=rawhide --requires python3-qt5 | grep python
libpython2.7.so.1.0
libpython2.7.so.1.0()(64bit)
python(abi) = 3.7
python3-qt5-base(x86-32) = 5.12.2-1.fc31
python3-qt5-base(x86-64) = 5.12.2-1.fc31

Sorry for the confusion.

Comment 3 Rex Dieter 2019-05-10 19:34:42 UTC
%changelog
* Fri May 10 2019 Rex Dieter <rdieter@fedoraproject.org> - 5.12.2-2
- python2-qt5-base: move qt plugins here (#1708274)


Turns out those are indeed python2 only

Comment 4 Raphael Groner 2019-05-10 19:39:04 UTC
Okay, then let's blame a recent update of python-qt5 in rawhide.

We'd consider to forward a bug to upstream, as this is not reproducible with version 5.11.3 currently in F30.

Comment 5 Miro Hrončok 2019-05-10 19:53:25 UTC
(In reply to Rex Dieter from comment #3)
> Turns out those are indeed python2 only

Are they really python2 only, or is it just thet they happen to be compiled with python2 and could be compiled with python 3 somehow?

Comment 6 Rex Dieter 2019-05-10 20:19:15 UTC
Didn't get that far, but I do suspect you can build either way but can ship only 1 (since they conflict)

Comment 7 Miro Hrončok 2019-05-10 20:22:24 UTC
The new build suffers from the same problem:

$ rpm -qp --requires python3-qt5-5.12.2-2.fc31.x86_64.rpm  | grep python
libpython2.7.so.1.0()(64bit)
python(abi) = 3.7
python3-qt5-base(x86-64) = 5.12.2-2.fc31

Comment 8 Rex Dieter 2019-07-07 22:56:12 UTC
Latest build appears ok to me,

Inspecting,
https://koji.fedoraproject.org/koji/rpminfo?rpmID=18022636

I see only
python(abi) = 3.7
and no references to libpython 

??

Comment 9 Rex Dieter 2019-07-07 23:00:25 UTC
Closing...

Comment 10 Miro Hrončok 2019-07-08 07:29:13 UTC
Indeed:

$ repoquery --repo=compose --requires python3-qt5 | grep python
python(abi) = 3.7
python3-qt5-base(x86-32) = 5.12.3-2.fc31
python3-qt5-base(x86-64) = 5.12.3-2.fc31

Thanks.


Note You need to log in before you can comment on or make changes to this bug.