Bug 17083 - RPM upgrade (-F or -U) of nfs-utils fails because a version number is misread
RPM upgrade (-F or -U) of nfs-utils fails because a version number is misread
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-29 13:45 EDT by jpranevich
Modified: 2008-10-27 14:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-19 11:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jpranevich 2000-08-29 13:45:58 EDT
When upgrading from nfs-utils-0.1.2-1 to nfs-utils-0.1.9.1 using rpm -Uivh, rpm reports that 0.1.2-1 is *newer* than 0.1.9.1-1. A similar problem 
is observed when upgrading to nfs-utils-0.1.6-2. I suspect the issue is with the third level minor revision number, but have not checked the 
source for an obvious fix.
Comment 1 Jeff Johnson 2000-10-12 12:12:17 EDT
This is a nfs-utils packaging problem. Changing component ...
Comment 2 Pete Zaitcev 2002-10-23 16:19:34 EDT
This is one super ancient bug.

I actually consulted Jeff, and he said it's likely the "Epoch" conflict.
The epoch is not visible in the RPM name, so SRPMs need to be compared.
If so, it's a bug, but since we are shipping 8.0 now, it's not something
I'm eager to investigate in detail.

Sorry...

Note You need to log in before you can comment on or make changes to this bug.