Bug 1708503 - [marketplace] Missing openapi CRD definitions for oc explain to work
Summary: [marketplace] Missing openapi CRD definitions for oc explain to work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Alexander Greene
QA Contact: Fan Jia
URL:
Whiteboard: 4.1.7
Depends On:
Blocks: 1723835
TreeView+ depends on / blocked
 
Reported: 2019-05-10 06:39 UTC by Jian Zhang
Modified: 2019-07-25 05:32 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The CatalogSourceConfig and OperatorSource Custom Resource Definitions (CRD) are missing the openapi definition fields. Consequence: "oc explain operatorsource" and "oc explain catalogsourceconfig" have empty descriptions. Fix: Update the CRDs with the `spec.validation.openAPIV3Schema.description` field. Result: Descriptions are now present when the "oc explain operatorsource" and "oc explain catalogsourceconfig" commands are ran.
Clone Of:
: 1712317 1723835 (view as bug list)
Environment:
Last Closed: 2019-07-25 05:32:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:1809 None None None 2019-07-25 05:32:37 UTC
Github operator-framework operator-marketplace pull 218 None None None 2019-07-12 19:53:13 UTC
Github operator-framework operator-marketplace pull 219 None None None 2019-07-12 20:01:08 UTC

Description Jian Zhang 2019-05-10 06:39:15 UTC
Description of problem:
Copied from bug 1705746, should add the description info for these CRDs so that `oc explain` can work.
mac:beta5 jianzhang$  oc explain operatorsource|grep -i description -A 3
DESCRIPTION:
     <empty>
mac:beta5 jianzhang$  oc explain csc|grep -i description -A 3
DESCRIPTION:
     <empty>

Version-Release number of selected component (if applicable):
Cluster version is 4.1.0-rc.2

How reproducible:
always

Steps to Reproduce:
1. Install the OCP 4.1.
2. Login this cluster as a cluster-admin.
3. Check the two CRDs and run the commands below in the backend.
$ oc explain operatorsource|grep -i description -A 3
$ oc explain csc|grep -i description -A 3

Actual results:
Get nothing about the descrioption.
mac:beta5 jianzhang$  oc explain operatorsource|grep -i description -A 3
DESCRIPTION:
     <empty>
mac:beta5 jianzhang$  oc explain csc|grep -i description -A 3
DESCRIPTION:
     <empty>

Expected results:
Should get the appropriate description for those two CRDs.

Additional info:

Comment 1 Alexander Greene 2019-05-10 18:40:34 UTC
The following PR has been opened to address this bug: https://github.com/operator-framework/operator-marketplace/pull/185


Problem:
The CatalogSourceConfig and OperatorSource Custom Resource Definitions
(CRD) are missing the openapi definition fields.

Solution:
Update the CRDs with the `spec.validation.openAPIV3Schema.description`
field.

Comment 2 Alexander Greene 2019-05-16 11:13:58 UTC
The PR above has been merged.

Comment 3 Fan Jia 2019-05-17 01:14:58 UTC
The latest nightly build (4.1.0-0.nightly-2019-05-16-223922) doesn't include the pr , will test until it includes it.

Comment 5 Fan Jia 2019-05-17 08:46:47 UTC
The latest nightly build (4.1.0-0.nightly-2019-05-17-041605) doesn't include the pr , will test until it includes it.

Comment 6 Fan Jia 2019-05-20 08:50:43 UTC
The branch release-4.1 doesn't include this pr, will be tested in 4.1.z.

Comment 10 Fan Jia 2019-05-27 02:21:01 UTC
The branch release-4.1 doesn't include this pr, will be tested in 4.1.z.

Comment 13 Fan Jia 2019-06-04 00:54:51 UTC
The branch release-4.1 doesn't include this pr, will be tested in 4.1.z.

Comment 19 Alexander Greene 2019-07-12 19:55:45 UTC
A new PR was created to add this to the 4.1 branch: https://github.com/operator-framework/operator-marketplace/pull/218

Comment 20 Luke Meyer 2019-07-18 03:05:51 UTC
That PR was closed, and resurrected as an automated cherry-pick
https://github.com/operator-framework/operator-marketplace/pull/219

which merged and was built, but nothing updated this bug.

Comment 24 errata-xmlrpc 2019-07-25 05:32:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1809


Note You need to log in before you can comment on or make changes to this bug.