Bug 1708506 - VirtualBox integration is failing in Rawhide
Summary: VirtualBox integration is failing in Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virtualbox-guest-additions
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-10 06:42 UTC by Ian Laurie
Modified: 2019-08-03 19:29 UTC (History)
4 users (show)

Fixed In Version: virtualbox-guest-additions-6.0.8-1.fc30 virtualbox-guest-additions-6.0.8-1.fc29 virtualbox-guest-additions-6.0.10-1.fc30 virtualbox-guest-additions-6.0.10-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-23 01:07:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian Laurie 2019-05-10 06:42:06 UTC
Description of problem:
Rawhide boots to a black graphical screen in VirtualBox.

Version-Release number of selected component (if applicable):
virtualbox-guest-additions-6.0.6-1.fc31.x86_64
kernel-5.1.0-0.rc7.git4.1.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Simply boot the virtual machine.
2.
3.

Actual results:
Boots to a black screen instead of the slick-greeter login (for MATE).

Expected results:
Should boot to the slick-greeter graphical login.

Additional info:
Launching a virtual console (Ctl-Alt-F2) and killing lightdm fixes the problem.

This issue may have existed in the kernel before the one shown above, this is simply the one I fist noticed the problem with.  This issue didn't exist with the kernel that was current a few weeks ago.

Comment 1 Ian Laurie 2019-05-10 22:52:05 UTC
I can confirm (from a backed up VM) that kernel-5.1.0-0.rc6.git2.1.fc31.x86_64 did not exhibit this problem.

Comment 2 Ian Laurie 2019-05-12 02:07:01 UTC
I'm not seeing the issue with latest kernel-5.1.0-1.fc31.x86_64 but that doesn't mean the underlying issue has been addressed of course.

Comment 3 Sergio Basto 2019-05-12 03:25:52 UTC
(In reply to Ian Laurie from comment #2)
> I'm not seeing the issue with latest kernel-5.1.0-1.fc31.x86_64 but that
> doesn't mean the underlying issue has been addressed of course.

why ? seems it is fixed .

May I close this bug ? 

Thanks for testing and reporting

Comment 4 Ian Laurie 2019-05-12 05:50:38 UTC
I don't believe it is fixed, I think it is some sort of race condition and I think this will come and go with different kernels until is is specifically addressed.  In any event close it off and I'll reopen it later if required.  In hindsight I think it is a kernel issue rather than a VirtualBox driver issue, we've seen problems before similar to this that have been the kernel.

Comment 5 Knud Christiansen 2019-05-15 18:20:22 UTC
I dont know if this is related to this bug

F31 kernel 5.1.0-1 as guest in VirtualBox 6.0.6 (KDE spin)
(Host F30)

Change screen resolution in guest does not work, after res. change it jumps immediately back to previous resolution.
Then maybe suddenly after a guest reboot it changes resolution from default 800x600 to something else but can still not changes the resolution.
Mouse pointer position is corrupted after trying changing resolution, can be fixed by HOSTkey + Fx going to Virtual console and back to GUI.
 
Knud

Comment 6 Fedora Update System 2019-05-19 17:04:05 UTC
virtualbox-guest-additions-6.0.8-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-1767174135

Comment 7 Fedora Update System 2019-05-19 17:04:19 UTC
virtualbox-guest-additions-6.0.8-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ef45b94699

Comment 8 Fedora Update System 2019-05-19 17:04:33 UTC
virtualbox-guest-additions-6.0.8-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e66a54910e

Comment 9 Knud Christiansen 2019-05-19 19:14:46 UTC
Has just tested with Host vbox 6.0.8 and the virtualbox-guest-additions 6.0.8
Same problem

Comment 10 Fedora Update System 2019-05-20 00:57:32 UTC
virtualbox-guest-additions-6.0.8-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-1767174135

Comment 11 Fedora Update System 2019-05-20 03:02:32 UTC
virtualbox-guest-additions-6.0.8-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e66a54910e

Comment 12 Fedora Update System 2019-05-20 11:43:42 UTC
virtualbox-guest-additions-6.0.8-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ef45b94699

Comment 13 Fedora Update System 2019-05-22 01:40:16 UTC
virtualbox-guest-additions-6.0.8-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Knud Christiansen 2019-05-22 05:00:08 UTC
For me this bug is not solved
Problem as described in comment #5 and #9 still persist

Shall I open a new bug ?

Comment 15 Sergio Basto 2019-05-22 14:38:14 UTC
OK reopen it .

I see new messages in vbox-users-community@lists.sourceforge.net with 
[VBox-users] Virtualbox display can't be moved (since recent update?)
is the same problem ?

Comment 16 Knud Christiansen 2019-05-22 15:13:38 UTC
From reading that problem "display can't be moved ....."

No I dont't think it is related or the same.

As described in comment #5
Additional info: 

Host actions works perfect.
Changing resolution by resizing the vbox window from the HOST, can be resize but the display area used by the guest stays the same.

Changing resolution from the guest (KDE spin F31 kernel 5.1.0-1 f31.x86_64 or f31 kernel 5.2.0-0.rc0.git.1)

You a short flickering and the resolution stays the same, mouse position (actual compared to visible) is corrupted.
Can partly be restored by shifting to fullscreen console in the guest by HOST+F2 =>HOST+F1

I have tried Guest desktops both Gnome, Cinnamon, either do the same or give an error.

It are complete fresh guest F31 installs

HOST is F30 ...but I dont believe it matters because problem was also with older F28 HOST

Using VboxSVGA, have tried the 2 other vbox display adapters VMSVGAm VboxVGA, does not affect the problem.

What logs shall I provide ?

Comment 17 Fedora Update System 2019-05-24 17:46:28 UTC
virtualbox-guest-additions-6.0.8-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-66a271ec02

Comment 18 Fedora Update System 2019-05-24 21:49:30 UTC
virtualbox-guest-additions-6.0.8-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2019-05-25 03:12:45 UTC
virtualbox-guest-additions-6.0.8-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-66a271ec02

Comment 20 Ian Laurie 2019-05-30 02:48:30 UTC
There are still problems.  

Screen resizing doesn't always work (usually doesn't) and now attempting to resize a screen breaks mouse integration (similar symptoms to that reported by Knud Christiansen).  

kernel-5.2.0-0.rc1
virtualbox-guest-additions-6.0.8-2.fc31

Getting a virtual console and killing lightdm will bring everything back until you try and resize the screen again.

Fedora 30 does not have these problems.

Comment 21 Michael Thayer 2019-05-30 07:12:03 UTC
Please see upstream VirtualBox ticket 18677[1], which Knud opened at my request.

[1]https://www.virtualbox.org/ticket/18677

Comment 22 Ian Laurie 2019-05-31 02:57:27 UTC
@Michael

Thanks I've added information to the upstream ticket after trying the test build VirtualBox-6.0.9-130970-Win.

Comment 23 Ian Laurie 2019-06-08 00:29:09 UTC
For me VirtualBox test build  VirtualBox-6.0.9-131183 fixes the issue completely.

Comment 24 Sergio Basto 2019-06-08 00:42:24 UTC
(In reply to Ian Laurie from comment #23)
> For me VirtualBox test build  VirtualBox-6.0.9-131183 fixes the issue
> completely.

Cool , it will be available on Fedora when 6.0.10 is released

Thanks for the report and testing

Comment 25 Knud Christiansen 2019-06-08 11:07:15 UTC

I can confirm that guest additions 6.0.9-131183.iso works in Linux F31 kernel 5.2.0-0.rc3.git0.1 as guest under F30 kernel 5.1.6-300.fc30.x86_64

Thank you :)

Knud

Comment 26 Fedora Update System 2019-07-18 22:13:50 UTC
FEDORA-2019-57faf7c6ea has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-57faf7c6ea

Comment 27 Fedora Update System 2019-07-18 22:16:29 UTC
FEDORA-2019-195a62c317 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-195a62c317

Comment 28 Fedora Update System 2019-07-19 01:34:46 UTC
virtualbox-guest-additions-6.0.10-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-57faf7c6ea

Comment 29 Fedora Update System 2019-07-19 03:25:58 UTC
virtualbox-guest-additions-6.0.10-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-195a62c317

Comment 30 Ian Laurie 2019-07-19 08:34:46 UTC
virtualbox-guest-additions-6.0.10 fixes the issues against the 5.2.x kernel but unfortunately Rawhide has moved to 5.3.x and again things are broken.  Upstream drives won't compile against kernel-5.3.0-0.rc0.git4.1.fc31.x86_64.

Comment 31 Knud Christiansen 2019-07-19 08:55:13 UTC
I can confirm Ian's observation

Comment 32 Knud Christiansen 2019-07-19 09:10:44 UTC
But it works with vboxguest + vboxvideo modules include in the kernel package (5.3.x)
Unfortunately I can see which vbox guest-additions version theese modules are based on

Comment 33 Knud Christiansen 2019-07-19 09:31:31 UTC
"Unfortunately I can NOT see"

Comment 34 Ian Laurie 2019-07-19 10:09:17 UTC
I can state categorically the kernel vboxvideo driver isn't working here on a Win 8.1 host.  On the other hand the failure isn't as miserable as some in the past.  I am not losing mouse integration, I am not getting black screens, and I don't have to grab a virtual console and restart lightdm to make things usable.  Basically what I am seeing is virtualbox is "remembering" the last good screen size, and if I try and deviate from that, I get [for example] scroll bars..... but the screen and mouse within the visible screen work, and the scroll bars work. and if I resize back to what it was things appear perfect again.  

So basically it's not working for me, but it isn't failing as badly as it used to.

@Knud you're on a Linux host correct?  Maybe that's the difference here.

Comment 35 Knud Christiansen 2019-07-19 10:21:11 UTC
yes host is F30
The symptoms you describe sounds similar what I have seen earlier
I have a I7 laptop with win7 as host....will give it a try there...
will report back...

Comment 36 Knud Christiansen 2019-07-19 10:40:35 UTC
Tested:

Host: WIN7 updated, Virtualbox 6.0.10 incl. extensions

Guest: F31 KDE spin Live 20190717 iso, running live as guest
Virtualbox host tells that guest is using additions 6.0.8

Everything works without any problem

Comment 37 Knud Christiansen 2019-07-19 10:52:59 UTC
@Ian
I have sent you an email...got rejected in your spam filter...please check

Comment 38 Ian Laurie 2019-07-19 10:59:52 UTC
@Knud Nothing my end but I don't have a spam filter running locally that would bounce back to you, not sure what went wrong, must be at the ISP level?

Comment 39 Ian Laurie 2019-07-19 11:09:12 UTC
I did a "dnf reinstall kernel*" to be sure but same issues, and I don't have Oracle's drivers on that box, so not sure why it's failing for me and working for you.

Comment 40 Knud Christiansen 2019-07-19 11:15:25 UTC
Email...Your ISP is really "aggressive"

5 different mail domains, 4 different mailservers....all get rejected

Comment 41 Ian Laurie 2019-07-19 11:17:26 UTC
@Knud Traditionally that's not the case.  Let me contact you via a web mail address, that bypasses them.

Comment 42 Ian Laurie 2019-07-22 00:50:37 UTC
kernel-5.3.0-0.rc0.git4.1.fc31.x86_64 with virtualbox-guest-additions-6.0.8-2.fc31.x86_64 (and default kernel drivers) on a Win7 host seems to work.  Not getting the issues I saw on the Win8.1 box.  After updating to kernel-5.3.0-0.rc0.git7.1.fc31.x86_64 it still seems to work.

I'll move this working VM to the Win8.1 box to see if it still works there.

Comment 43 Michael Thayer 2019-07-22 09:05:49 UTC
Just as a reminder, reporting issues which can be reproduced with upstream VirtualBox builds directly on virtualbox.org is appreciated.  (Binaries preferred over own builds for reproducing things, as they eliminate a few more unknowns; this does not necessarily apply to people willing to do their own source-level debugging.)

Comment 44 Ian Laurie 2019-07-22 10:42:59 UTC
@Michael I did report the failure of the 6.0.10 drivers not building against kernel 5.3.0-0.rc0.git4.1.fc31.x86_64 here:

https://forums.virtualbox.org/viewtopic.php?f=3&t=93944

The VM that was working correctly on Win7 works when I moved it to Win8.1 which is perplexing.  The only difference between the VMs that I can think of is that the working one never had Oracle's upstream drivers installed on it.  However they were cleanly uninstalled using the uninstall.sh and the kernel* was reinstalled for good measure after.  So I cannot explain it.

In any case I am now observing the same working behavior that Knud reported in comment 36.

Comment 45 Fedora Update System 2019-07-23 01:07:50 UTC
virtualbox-guest-additions-6.0.10-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 46 Sergio Basto 2019-07-23 20:41:28 UTC
(In reply to Michael Thayer from comment #43)
> Just as a reminder, reporting issues which can be reproduced with upstream
> VirtualBox builds directly on virtualbox.org is appreciated.  (Binaries
> preferred over own builds for reproducing things, as they eliminate a few
> more unknowns; this does not necessarily apply to people willing to do their
> own source-level debugging.)

But kernel modules build problems, we show move to RPMFusion https://bugzilla.rpmfusion.org/enter_bug.cgi?product=Fedora&component=VirtualBox since most probably is for VirtualBox server and not for vboxsf.ko , vboxsf.ko is the only module that isn't in include in Fedora kernel for guest adittions.

Comment 47 Fedora Update System 2019-07-29 01:44:53 UTC
virtualbox-guest-additions-6.0.10-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 48 Sergio Basto 2019-08-03 19:29:54 UTC
(In reply to Ian Laurie from comment #42)
> kernel-5.3.0-0.rc0.git4.1.fc31.x86_64 with
> virtualbox-guest-additions-6.0.8-2.fc31.x86_64 (and default kernel drivers)
> on a Win7 host seems to work.  Not getting the issues I saw on the Win8.1
> box.  After updating to kernel-5.3.0-0.rc0.git7.1.fc31.x86_64 it still seems
> to work.
> 
> I'll move this working VM to the Win8.1 box to see if it still works there.

akmod-VirtualBox-6.0.10-2.fc31.x86_64 have fixes for kernel-5.3 and is already available


Note You need to log in before you can comment on or make changes to this bug.