Bug 1708701 - ValueError: invalid literal for int() with base 10: 'Volume'
Summary: ValueError: invalid literal for int() with base 10: 'Volume'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 29
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-10 15:37 UTC by Ben Williams
Modified: 2019-05-29 00:49 UTC (History)
10 users (show)

Fixed In Version: anaconda-31.13-1 anaconda-30.25.6-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-29 00:49:49 UTC


Attachments (Terms of Use)
anaconda log (18.64 KB, text/plain)
2019-05-10 17:50 UTC, Ben Williams
no flags Details
flat-kde.ks (12.22 KB, text/plain)
2019-05-10 17:52 UTC, Ben Williams
no flags Details

Description Ben Williams 2019-05-10 15:37:44 UTC
Description of problem:
updated lives fail to build

Version-Release number of selected component (if applicable):
current and also in the future version of lorax in koji

How reproducible:

everytime
Steps to Reproduce:
1.
2.
3.

Actual results:
https://paste.fedoraproject.org/paste/yyIBqaf6d0cRewywmbIGTA

Expected results:


Additional info:

Comment 1 Brian Lane 2019-05-10 16:58:12 UTC
I need more information to narrow this down. It is failing inside anaconda with:

ValueError: invalid literal for int() with base 10: 'Volume'

So I at least need the anaconda logs from this attempt. The kickstart and cmdline used would also be helpful.

Comment 2 Ben Williams 2019-05-10 17:50:59 UTC
Created attachment 1566747 [details]
anaconda log

Comment 3 Ben Williams 2019-05-10 17:52:32 UTC
Created attachment 1566748 [details]
flat-kde.ks

Comment 4 Ben Williams 2019-05-10 17:53:10 UTC
livemedia-creator --ks /usr/share/spin-kickstarts/flat-kde.ks --no-virt --resultdir /var/lmc --project Fedora-KDE-Live --make-iso --volid F29-x86_64-KDE --iso-only --iso-name F29-KDE-x86_64-20190510.iso --releasever 29 --title F29-KDE-x86_64 --macboot

Comment 5 Brian Lane 2019-05-10 20:02:22 UTC
I tried this locally and cannot reproduce it with:

lorax-29.27-1.fc29.x86_64
anaconda-tui-29.24.7-2.fc29.x86_64
dnf-4.2.5-1.fc29.noarch
libdnf-0.31.0-2.fc29.x86_64

Moving to anaconda to see if they have any ideas.

Comment 6 Vendula Poncova 2019-05-13 10:33:30 UTC
I was able to reproduce the issue during an installation to VM with a device mounted at "/tmp/My Volume". Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1965

Comment 7 Ben Williams 2019-05-23 14:00:42 UTC
hopefully it builds and is backported to f29 soon (it is stopping the Respins Sig from releasing updated isos for the community

Comment 8 Fedora Update System 2019-05-27 14:15:13 UTC
anaconda-29.24.7-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-06a2d1c7fb

Comment 9 Fedora Update System 2019-05-27 15:06:32 UTC
anaconda-30.25.6-3.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2ae2d52f4e

Comment 10 Fedora Update System 2019-05-28 02:28:11 UTC
anaconda-30.25.6-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2ae2d52f4e

Comment 11 Fedora Update System 2019-05-28 03:50:10 UTC
anaconda-29.24.7-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-06a2d1c7fb

Comment 12 Martin Kolman 2019-05-28 08:43:56 UTC
(In reply to Ben Williams from comment #7)
> hopefully it builds and is backported to f29 soon (it is stopping the
> Respins Sig from releasing updated isos for the community

I've done Anaconda builds for F29 and F30 with the patch from comment 6 on top. You can test & karma the respective bodhi updates to make the build reach stable repositories sooner. :)

Comment 13 Ben Williams 2019-05-28 17:33:42 UTC
see https://bugzilla.redhat.com/show_bug.cgi?id=1714726 for use with new anaconda

Comment 14 Fedora Update System 2019-05-29 00:49:49 UTC
anaconda-30.25.6-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.