Bug 170891 - Improve integration of evolution and gnome-panel
Improve integration of evolution and gnome-panel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On: 172234
Blocks: Yellowpad
  Show dependency treegraph
 
Reported: 2005-10-14 23:11 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 15:45:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 162305 None None None Never
GNOME Desktop 270751 None None None Never

  None (edit)
Description Matthias Clasen 2005-10-14 23:11:46 EDT
Double-clicking on the panel clock's calendar brings up the evolution calendar,
but it doesn't show the day that was selected in the clock's calendar. It should.

Also, it should close the clock's calendar and use startup notification, since
it takes some time for evolution to come up.
Comment 1 Dave Malcolm 2005-10-27 18:26:19 EDT
Yes, it seems to come up with a new window containing whatever view the last
calendar window had selected (e.g. week view, month view, etc).  I agree that it
should show the day view for the day you double-clicked on.
Comment 2 Dave Malcolm 2005-11-01 14:43:02 EST
Looks like the necessary work has already been done and is sitting unapplied in
upstream bugzilla; gnome-panel clock needs patching, evolution doesn't:
http://bugzilla.gnome.org/show_bug.cgi?id=162305

Changing component to gnome-panel and reassigning.
Comment 3 Dave Malcolm 2005-11-01 14:44:58 EST
Oops; didn't see the evolution patch as well...

So both evolution and gnome-panel will need patching...
Comment 4 Dave Malcolm 2005-11-01 14:50:18 EST
(I created bug 172234 to track the necessary work to evolution that will need to
happen before the gnome-panel patch will work)
Comment 5 Dave Malcolm 2005-11-01 15:06:44 EST
Reassigning back to me to keep it easier to work on.
Comment 6 Christopher Aillon 2006-01-27 15:45:16 EST
We'll pull this in when it gets into upstream.  There are appropriate upstream
bugs which will handle it and there's no reason to diverge from them, which
could potentially introduce bugs.  Marking UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.