Bug 1708970 - [OSP15] Fix OVS DPDK step_config input
Summary: [OSP15] Fix OVS DPDK step_config input
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Saravanan KR
QA Contact: Yariv
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-12 04:18 UTC by Vadim Khitrin
Modified: 2019-09-26 10:50 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190528190414.f41e7e4.1.el8ost.noarch.rpm
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1828413 0 None None None 2019-05-12 04:18:26 UTC
OpenStack gerrit 658290 0 None None None 2019-05-12 04:18:26 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:22:17 UTC

Description Vadim Khitrin 2019-05-12 04:18:26 UTC
Description of problem:
During deployment of Overcloud with ML2 OVS backend, a step in heat template is missing which will cause failure to boot instances with DPDK NICs.


Version-Release number of selected component (if applicable):
rpm -qa | grep tripleo
ansible-role-tripleo-modify-image-1.0.1-0.20190422122515.f1dfdc6.el8ost.noarch
openstack-tripleo-heat-templates-10.5.1-0.20190426040357.0b61dd0.el8ost.noarch
puppet-tripleo-10.4.2-0.20190426000346.bc825d0.el8ost.noarch
openstack-tripleo-common-containers-10.7.1-0.20190426083235.1988c18.el8ost.noarch
python3-tripleoclient-heat-installer-11.4.1-0.20190424070351.41fa2fc.el8ost.noarch
openstack-tripleo-validations-10.4.1-0.20190426070346.e774685.el8ost.noarch
python3-tripleo-common-10.7.1-0.20190426083235.1988c18.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190424070351.41fa2fc.el8ost.noarch
openstack-tripleo-image-elements-10.4.1-0.20190426080346.7efbd4c.el8ost.noarch
openstack-tripleo-common-10.7.1-0.20190426083235.1988c18.el8ost.noarch
ansible-tripleo-ipsec-9.1.1-0.20190422122014.8c1fdab.el8ost.noarch
openstack-tripleo-puppet-elements-10.3.1-0.20190426070355.a359301.el8ost.noarch


How reproducible:
Always


Steps to Reproduce:
1. Deploy Overcloud with ML2 OVS backend
2. Boot instance with DPDK NICs

Actual results:
Instance fails to boot.

Expected results:
Successful boot of instance.

Additional info:
A patch which was tested and verified exists in upstream which needs to be backported.

Comment 7 errata-xmlrpc 2019-09-21 11:21:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.