This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 17090 - maestro.o has enormous loads when using rat
maestro.o has enormous loads when using rat
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-29 15:12 EDT by m wolf
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 20:26:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description m wolf 2000-08-29 15:12:35 EDT
My load went into the 90's when using robust audio tool on a Dell Inspiron
7000.
Used the same rat rpm on several other non-maestro computers and the load
is in the 4% range.  Rat's homepage reports problems with maestro
specifically in the FAQ.
http://www-mice.cs.ucl.ac.uk/multimedia/software/rat
I am using maestro module v0.14.
This may affect other recording tools?
-m
Comment 1 Alan Cox 2000-09-15 13:45:52 EDT
Can you get an strace of rat doing this and attach a chunk of it ?

Also does the 2.2.16 RH errata kernel help. Some maestro stuff got fixed
Comment 2 m wolf 2000-09-19 17:50:52 EDT
just installed pinstripe which uses 2.2.16 and that didn't help.
i'll email you the strace because rat does realtime stuff and is constantly
getting the time which makes for a huge strace file.
-michael
Comment 3 Alan Cox 2002-12-14 20:26:39 EST
maestro wakeup was indeed buggy a long time ago, and fixed.

Note You need to log in before you can comment on or make changes to this bug.