Bug 170908 - Additional page printed on samba simplex jobs printing to cups duplex printer definition
Additional page printed on samba simplex jobs printing to cups duplex printer...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cups (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2005-10-15 09:09 EDT by EE CAP Admin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 06:11:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PPD file I'm using for HPLJ4200 for duplex printer (57.81 KB, application/octet-stream)
2005-10-15 09:12 EDT, EE CAP Admin
no flags Details
CUPS spool file from windows print job (123.45 KB, application/octet-stream)
2005-10-15 09:21 EDT, EE CAP Admin
no flags Details
CUPS spool file from CUPS/Linux print job (317.60 KB, application/octet-stream)
2005-10-15 09:22 EDT, EE CAP Admin
no flags Details
sysreport from the print server (830.31 KB, application/x-bzip2)
2005-10-21 06:58 EDT, EE CAP Admin
no flags Details
Configured PPD file that's in use (56.61 KB, application/octet-stream)
2006-06-26 12:04 EDT, EE CAP Admin
no flags Details

  None (edit)
Description EE CAP Admin 2005-10-15 09:09:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
Dear Tim,

I have the following setup:

Printer queues defined on a cups print server using vendor supplied PPD files.  The defaults on the cups server are set to print duplex.

Samba is configured for windows clients to use the windows 2000 PS driver (files actually taken off a win2003 box) downloaded from the [print$] share.  The drivers were registered with samba using the cupsaddsmb command.  The defaults on the samba printers are set identically to the cups definitions (i.e. duplexing is turned on by default in both cases).

Printing from an EL4 machine with cups, the print jobs work perfectly.

If I print a job to a duplex printer from windows to the samba printer definitions, then the following behaviour happens:

1. A duplex job prints fine.

2. A simplex job with an odd number of pages, an additional blank page comes out of the printer (as if to make it up to an even number of pages for a duplex job)

If I set the defaults on cups and [print$] to be simplex, then the problem goes away but I do not want to do this as people will then waste paper.

Paul

Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.9.8

How reproducible:
Always

Steps to Reproduce:
1. install a duplex printer on cups with duplex as default
2. set up a samba share for the printer and register drivers using cupsaddsmb
3. print from windows to the share.  An additional (blank) page will be present if the job is requested as simplex from windows.
  

Actual Results:  Print 3 pages document simplex over samba, and a 4th (blank) page comes out.

Expected Results:  3 pages come out of the printer

Additional info:

I will upload an example PPD file, and the print spool file of a page printed from samba and from cups in a moment.
Comment 1 EE CAP Admin 2005-10-15 09:12:56 EDT
Created attachment 120014 [details]
PPD file I'm using for HPLJ4200 for duplex printer

This is the PPD I am using for the cups definition of one of the duplexing
printers which exhibits the behaviour (all the duplex printers we have behave
in this way) .	As I used cupsaddsmb, it is also the same PPD that is being
used by windows.
Comment 2 EE CAP Admin 2005-10-15 09:21:01 EDT
Created attachment 120015 [details]
CUPS spool file from windows print job

This is the spool file from windows for a PDF file printed in acrobat 7 pro to
a samba print definition as a simplex job (as it ended up on the cups spool
/var/spool/cups).  This single page, plus a blank page, come out of the
printer.
Comment 3 EE CAP Admin 2005-10-15 09:22:52 EDT
Created attachment 120016 [details]
CUPS spool file from CUPS/Linux print job

This is the spool file from a linux print job for the same PDF file printed in
acroread 7 to a cups print definition (of the same printer) as a simplex job
(as it ended up on the cups spool /var/spool/cups).  This single page, and it
printed fine, as a single page.
Comment 4 EE CAP Admin 2005-10-18 13:34:02 EDT
Tim,

I have now added a service request:

Service Request: 710332

And I have linked it to this bugzilla entry.

Thanks,

Paul
Comment 5 Jon Fautley 2005-10-20 12:48:51 EDT
Paul,

I have been assigned this issue by our Global Support Services department due to
the level of support you have on your products.

If possible, would you be able to close the existing Service Request, and we
shall continue the call process through this bugzilla?

Many Thanks,

Jon Fautley
Technical Consultant
Red Hat
Comment 6 EE CAP Admin 2005-10-20 12:58:06 EDT
Hi Jon,

I have added a note to the service request to close.  Let's hope we can solve
this problem using this bugzilla entry.

Cheers,

Paul
Comment 7 Jon Fautley 2005-10-21 05:38:09 EDT
Paul,

Would it be possible for you to attach a sysreport from the system running
CUPS+SAMBA to this bugzilla? You can find details on creating a sysreport here:

http://kbase.redhat.com/faq/FAQ_80_456.shtm

If you require any further information or assistance, please do not hestiate to
contact me.

Best Regards,

Jon Fautley
Technical Consultant
Red Hat
Comment 8 Jon Fautley 2005-10-21 06:21:12 EDT
Paul,

Upon further investigation, I believe I may have found the cause of your
spurious page being printed.

There appears to be a difference in the way a Windows system and a Linux system
will print Postscript documents. A Windows system will automatically append a
<Ctrl-D> to the end of the print job, causing an extra form feed, and thus the
blank page. Linux does not append this <Ctrl-D> character, as the print spooler
system (CUPS) does this automatically. As a result, the printer is sent two 'End
of Job' markers when printing from a Windows system, resulting in the extra page
being printed.

You can disable this in the following manner:

* Log on to your Windows Desktop (You will probably need Administrator rights to
change printer properties)
* Go to Start->Settings->Printers
* Right-Click on the correct printer icon corresponding to your shared Laser
Printer, and select Properties
* Go to the last tab, Device Settings
* Change the option that reads 'Send Ctrl-D after each job' from 'Yes' to 'No'
* Attempt to print a document and ensure that no extra page is printed.

Best Regards,

Jon

Comment 9 EE CAP Admin 2005-10-21 06:44:06 EDT
Dear Jon,

sysreport coming in a minute.... it's just running.

I had already tried the control d settings in the windows driver and it did not
make any difference.  You'll notice that this only occurs if you print an odd
number of pages - it is not happening on every print and consequently I was not
too surprised that control d didn't fix it.

I think the issue is that something (cups?) is trying to always make the job up
to an even number of pages, thinking that the job is duplex, even when it isn't.
 (I think that a duplex job must have an even number of pages or the final page
will not come out of the printer?)

Thanks,

Paul
Comment 10 EE CAP Admin 2005-10-21 06:58:16 EDT
Created attachment 120248 [details]
sysreport from the print server

Hi Jon,

Here is a sysreport from our print server machine.

Thanks,

Paul
Comment 11 EE CAP Admin 2005-10-25 10:32:25 EDT
Hi Jon,

Any more ideas yet?

Paul
Comment 12 Tim Waugh 2006-06-26 11:20:43 EDT
Paul, the PPD from comment #1 seems to have DuplexUnit set to NotInstalled in
the  InstallableOptions section.  Is this the PPD as you're actually using it,
or before it's been adjusted?
Comment 13 EE CAP Admin 2006-06-26 12:01:55 EDT
Hi Tim,

As you suggest I think I must have uploaded a raw ppd file before making the
changes.

I'll upload the one that's actually in use in  a second. 

Ah yes - the one I'm about to upload has the duplex option set to installed.

Thanks for looking at this.

Paul
Comment 14 EE CAP Admin 2006-06-26 12:04:15 EDT
Created attachment 131552 [details]
Configured PPD file that's in use

This obsoletes file 120014
Comment 15 Tim Waugh 2006-06-29 06:11:47 EDT
I reported this upstream:

  http://www.cups.org/str.php?L1802

The upstream opinion is that this is an issue with the Windows driver.

Note You need to log in before you can comment on or make changes to this bug.