Bug 1709247 - coreos.inst.image_url do not support url redirection
Summary: coreos.inst.image_url do not support url redirection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Steve Milner
QA Contact: Micah Abbott
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-13 09:23 UTC by weiwei jiang
Modified: 2019-06-04 10:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:48:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:48:47 UTC

Description weiwei jiang 2019-05-13 09:23:21 UTC
Description of problem:
when try to install coreos with image_url which targeted to a url with 302 response,
rhcos installation will succeed but can not boot from disk.

Version-Release number of selected component (if applicable):
Build 410.8.20190509.5

How reproducible:
Always

Steps to Reproduce:
1. configure coreos.inst.image_url to a url with 302 response
2. wail rhcos installation succeed and boot from disk
3.

Actual results:
2. reboot from disk fail, and no more requests to deal with the 302 response
192.168.222.106 - - [13/May/2019:03:38:16 -0400] "HEAD /rhcos_files/baremetal-lab-01/metal-bios.raw.gz HTTP/1.1" 302 - "-" "curl/7.61.1"
192.168.222.106 - - [13/May/2019:03:38:16 -0400] "GET /rhcos_files/baremetal-lab-01/metal-bios.raw.gz HTTP/1.1" 302 303 "-" "curl/7.61.1"

Expected results:
2. rhcos installation should succeed and boot work well with disk

Additional info:

Comment 1 Steve Milner 2019-05-13 12:55:58 UTC
Thank you for this report! We're on it!

Comment 3 Steve Milner 2019-05-13 13:17:41 UTC
Initial PR: https://github.com/coreos/coreos-installer/pull/28

Comment 7 weiwei jiang 2019-05-14 03:30:10 UTC
Checked with 410.8.20190513.0 and url redirection work well, so move to verified.

# cat _01-b4-96-91-1c-3d-48-worker-http
DEFAULT pxeboot
TIMEOUT 20
PROMPT 0
LABEL pxeboot
    KERNEL http://192.168.222.22:8000/rhcos_files/baremetal-lab-01/installer-kernel
    APPEND ip=dhcp rd.neednet=1 initrd=http://192.168.222.22:8000/rhcos_files/baremetal-lab-01/installer-initramfs.img console=tty0 console=ttyS0 coreos.inst=yes coreos.inst.install_dev=sda coreos.inst.image_url=http://192.168.222.22:8000/rhcos_files/baremetal-lab-01/metal-bios.raw.gz coreos.inst.ignition_url=http://192.168.222.22:8000/rhcos/ignitions/worker.ign
IPAPPEND 2

# Logs from httpd access_log:
192.168.222.106 - - [13/May/2019:22:53:34 -0400] "GET /pxelinux.0 HTTP/1.1" 200 42780 "-" "iPXE/1.0.0+ (ebf2)"                                                                                                                                                                 
192.168.222.106 - - [13/May/2019:22:53:34 -0400] "GET /ldlinux.c32 HTTP/1.1" 200 116132 "-" "iPXE/1.0.0+ (ebf2)"
192.168.222.106 - - [13/May/2019:22:53:34 -0400] "GET /pxelinux.cfg/44454c4c-3100-1031-8058-b7c04f435032 HTTP/1.1" 404 247 "-" "iPXE/1.0.0+ (ebf2)"
192.168.222.106 - - [13/May/2019:22:53:34 -0400] "GET /pxelinux.cfg/01-b4-96-91-1c-3d-48 HTTP/1.1" 200 510 "-" "iPXE/1.0.0+ (ebf2)"
192.168.222.106 - - [13/May/2019:22:53:34 -0400] "GET /rhcos_files/baremetal-lab-01/installer-kernel HTTP/1.1" 302 302 "-" "iPXE/1.0.0+ (ebf2)"
192.168.222.106 - - [13/May/2019:22:53:34 -0400] "GET /rhcos_assets/storage/releases/ootpa/410.8.20190513.0/rhcos-410.8.20190513.0-installer-kernel HTTP/1.1" 200 7872864 "-" "iPXE/1.0.0+ (ebf2)"
192.168.222.106 - - [13/May/2019:22:53:41 -0400] "GET /rhcos_files/baremetal-lab-01/installer-initramfs.img HTTP/1.1" 302 309 "-" "iPXE/1.0.0+ (ebf2)"                                                                                                                                                                                                                                                                                                                                                                         
192.168.222.106 - - [13/May/2019:22:53:41 -0400] "GET /rhcos_assets/storage/releases/ootpa/410.8.20190513.0/rhcos-410.8.20190513.0-installer-initramfs.img HTTP/1.1" 200 57769525 "-" "iPXE/1.0.0+ (ebf2)"
192.168.222.106 - - [13/May/2019:22:55:26 -0400] "HEAD /rhcos_files/baremetal-lab-01/metal-bios.raw.gz HTTP/1.1" 302 - "-" "curl/7.61.1"
192.168.222.106 - - [13/May/2019:22:55:26 -0400] "HEAD /rhcos_assets/storage/releases/ootpa/410.8.20190513.0/rhcos-410.8.20190513.0-metal-bios.raw.gz HTTP/1.1" 200 - "-" "curl/7.61.1"
192.168.222.106 - - [13/May/2019:22:55:27 -0400] "GET /rhcos/ignitions/worker.ign HTTP/1.1" 200 1849 "-" "curl/7.61.1"
192.168.222.106 - - [13/May/2019:22:55:27 -0400] "GET /rhcos_files/baremetal-lab-01/metal-bios.raw.gz HTTP/1.1" 302 303 "-" "curl/7.61.1"
192.168.222.106 - - [13/May/2019:22:55:27 -0400] "GET /rhcos_assets/storage/releases/ootpa/410.8.20190513.0/rhcos-410.8.20190513.0-metal-bios.raw.gz HTTP/1.1" 200 714118068 "-" "curl/7.61.1"

Comment 9 errata-xmlrpc 2019-06-04 10:48:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.