Bug 170926 - gfs does not respect loss of quorum (split brain?)
gfs does not respect loss of quorum (split brain?)
Status: CLOSED DUPLICATE of bug 162725
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: David Teigland
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-15 15:45 EDT by Axel Thimm
Modified: 2010-01-11 22:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 15:45:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2005-10-15 15:45:32 EDT
Description of problem:
When a cluster looses quorum, cluster members can still read/write from/to a gfs
mount.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-22.EL
GFS-kernel-smp-2.6.9-42.1
cman-kernel-smp-2.6.9-39.5
GFS-6.1.2-0
cman-1.0.2-0

How reproducible:
always

Steps to Reproduce:
1.create a three node cluster and use a shared gfs mount.
2.shutdown the cluster services on two nodes
3.continue using the gfs mount on the third node
  
Actual results:
Read/write operations are possible even though the cluster has lost quorum.

Expected results:
gfs should respect cman's "quorum lost, blocking activity" (or cman should
freeze the gfs mount until quorum is regained).

Additional info:
This bug possibly explains the split brain behaviour of bug #169693.
Comment 1 David Teigland 2005-10-31 15:45:28 EST
This is the correct behavior as explained in bz 162725.
If a cluster loses quorum but none of the nodes mounting
gfs fs "foo" have failed, then there's no need to block
locking for foo (that's only needed to safely do journal
recovery.)  While the cluster is inquorate, no nodes are
permitted to mount or unmount any gfs file systems, though.

If there's a cluster partition, nodes on the inquorate side
will be fenced by the quorate side before any nodes on the
quorate side can mount any gfs file systems.  So, if there
are nodes using "foo" in an inquorate cluster, and a cluster
partition gains quorum, those nodes using foo will be fenced
before any nodes in the quorate cluster mount foo.

*** This bug has been marked as a duplicate of 162725 ***

Note You need to log in before you can comment on or make changes to this bug.