Bug 170929 - no sound on 2.6.12-1.1378_FC3 alsa intel i810
no sound on 2.6.12-1.1378_FC3 alsa intel i810
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-15 19:49 EDT by Frank DiPrete
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-16 09:43:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank DiPrete 2005-10-15 19:49:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
no sound (alsa) using an intel i810 board (dell) AC97 snd_intel_8x0
updated alsa to 1.09b, alsaconf finds the card, set up mixer, no sound
clicks and pops when udev runs or alsaconf runs
mixer and sound card detection find it, test sound does not play
tried the "mute the mic" trick, no change







Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1378_FC3

How reproducible:
Always

Steps to Reproduce:
1.install/update fc3
2.configure sound
3.try to play aound file
  

Actual Results:  no sound

Expected Results:  sound

Additional info:

lsmod:

snd_intel8x0           34880  2
snd_ac97_codec         78076  1 snd_intel8x0
snd_pcm_oss            51616  0
snd_mixer_oss          18432  2 snd_pcm_oss
snd_pcm                98952  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              33412  1 snd_pcm
snd                    58884  8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10785  2 snd
snd_page_alloc         10244  2 snd_intel8x0,snd_pcm

dmesg:

intel8x0_measure_ac97_clock: measured 49941 usecs
intel8x0: clocking to 48000

lspci:

00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
Comment 1 Frank DiPrete 2005-10-16 09:43:30 EDT
OK - found a work around.

By chance I tried un-muting the HEADPHONE control. With headphone jack sense
muted and headphone un-muted there is now sound. The headphone volume control
also controls the level of sound output.

There are 3 audio jacks on the system. line in, mic in and line out. For some
reason in this version of Fedora/Alsa the headphone volume control controls the
line out.

Found by luck.

Note You need to log in before you can comment on or make changes to this bug.