Bug 1709453 - Re-emergence of a old (unreported?) bug: Modular dependency problems
Summary: Re-emergence of a old (unreported?) bug: Modular dependency problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-13 15:43 UTC by b0a387e2
Modified: 2019-09-06 12:31 UTC (History)
9 users (show)

Fixed In Version: dnf-4.2.8-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-06 12:31:02 UTC


Attachments (Terms of Use)

Description b0a387e2 2019-05-13 15:43:06 UTC
Description of problem:

Similar to these/this:
https://forums.fedoraforum.org/showthread.php?320242-Modular-dependency-problems-(Fedora-29)
https://huhuidong.wordpress.com/2018/12/19/modular-dependency-problems-conflicting-requests-fedora-29/

Suddenly, long after my upgrade to f30 - which was without incident, I began seeing these (below) messages on my attempts to upgrade. This was perhaps a few days ago.

**CLI BEGINS** (for today)
[Prompt] sudo dnf update --refresh                                                                                            
Fedora Modular 30 - x86_64                                                                          135 kB/s |  24 kB     00:00    
Fedora - Rawhide - Developmental packages for the next Fedora release                               114 kB/s |  19 kB     00:00    
Fedora Modular 30 - x86_64 - Updates                                                                134 kB/s |  23 kB     00:00    
Fedora 30 - x86_64 - Updates                                                                        132 kB/s |  22 kB     00:00    
Fedora 30 - x86_64 - Updates                                                                        1.0 MB/s | 570 kB     00:00    
Fedora 30 - x86_64                                                                                  135 kB/s |  24 kB     00:00    
Google Cloud SDK                                                                                    1.0 kB/s | 454  B     00:00    
RPM Fusion for Fedora 30 - Free - Updates                                                            21 kB/s | 9.4 kB     00:00    
RPM Fusion for Fedora 30 - Free                                                                      19 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree - Updates                                                         22 kB/s | 9.6 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree                                                                   24 kB/s |  10 kB     00:00    
Modular dependency problems:

 Problem 1: conflicting requests
  - nothing provides module(platform:f30) needed by module stratis:1:3020190306064421:a5b0195c-0.x86_64
 Problem 2: conflicting requests
  - nothing provides module(platform:f30) needed by module rpick:latest:3020190313083345:a5b0195c-0.x86_64
 Problem 3: conflicting requests
  - nothing provides module(platform:f30) needed by module ripgrep:latest:3020190403201826:a5b0195c-0.x86_64
 Problem 4: conflicting requests
  - nothing provides module(platform:f30) needed by module newsboat:latest:3020190325084033:a5b0195c-0.x86_64
 Problem 5: conflicting requests
  - nothing provides module(platform:f30) needed by module meson:latest:3020190310183600:36245242-0.x86_64
 Problem 6: conflicting requests
  - nothing provides module(platform:f30) needed by module hyperfine:latest:3020190318171218:a5b0195c-0.x86_64
 Problem 7: conflicting requests
  - nothing provides module(platform:f30) needed by module heatseeker:latest:3020190309110310:a5b0195c-0.x86_64
 Problem 8: conflicting requests
  - nothing provides module(platform:f30) needed by module gimp:2.10:3020190304180601:a5b0195c-0.x86_64
 Problem 9: conflicting requests
  - nothing provides module(platform:f30) needed by module ffsend:latest:3020190407071859:a5b0195c-0.x86_64
 Problem 10: conflicting requests
  - nothing provides module(platform:f30) needed by module exa:latest:3020190306064823:e50d0d19-0.x86_64
 Problem 11: conflicting requests
  - nothing provides module(platform:f30) needed by module bat:latest:3020190307100850:e50d0d19-0.x86_64
 Problem 12: conflicting requests
  - nothing provides module(platform:f30) needed by module tokei:rolling:3020190424130518:552c3bf4-0.x86_64
 Problem 13: conflicting requests
  - nothing provides module(platform:f30) needed by module stratis:1:3020190424132827:2c789dff-0.x86_64
 Problem 14: conflicting requests
  - nothing provides module(platform:f30) needed by module rpick:latest:3020190505074712:2c789dff-0.x86_64
 Problem 15: conflicting requests
  - nothing provides module(platform:f30) needed by module ripgrep:latest:3020190424130455:2c789dff-0.x86_64
 Problem 16: conflicting requests
  - nothing provides module(platform:f30) needed by module newsboat:latest:3020190424132544:2c789dff-0.x86_64
 Problem 17: conflicting requests
  - nothing provides module(platform:f30) needed by module meson:latest:3020190417114446:36245242-0.x86_64
 Problem 18: conflicting requests
  - nothing provides module(platform:f30) needed by module hyperfine:latest:3020190424130645:2c789dff-0.x86_64
 Problem 19: conflicting requests
  - nothing provides module(platform:f30) needed by module heatseeker:latest:3020190424131839:2c789dff-0.x86_64
 Problem 20: conflicting requests
  - nothing provides module(platform:f30) needed by module gimp:2.10:3020190409123811:a5b0195c-0.x86_64
 Problem 21: conflicting requests
  - nothing provides module(platform:f30) needed by module ffsend:latest:3020190505074553:2c789dff-0.x86_64
 Problem 22: conflicting requests
  - nothing provides module(platform:f30) needed by module fd-find:rolling:3020190427173626:2c789dff-0.x86_64
 Problem 23: conflicting requests
  - nothing provides module(platform:f30) needed by module exa:latest:3020190424131210:552c3bf4-0.x86_64
 Problem 24: conflicting requests
  - nothing provides module(platform:f30) needed by module bat:latest:3020190424130937:552c3bf4-0.x86_64
 Problem 25: conflicting requests
  - nothing provides module(platform:f30) needed by module askalono-cli:rolling:3020190424143105:2c789dff-0.x86_64
 Problem 26: conflicting requests
  - nothing provides module(platform:f30) needed by module afterburn:rolling:3020190507144241:2c789dff-0.x86_64
 Problem 27: conflicting requests
  - nothing provides module(platform:f30) needed by module avocado:stable:3020190304180315:a5b0195c-0.x86_64
 Problem 28: conflicting requests
  - nothing provides module(platform:f30) needed by module dwm:6.1:3020190304180429:a5b0195c-0.x86_64
 Problem 29: conflicting requests
  - nothing provides module(platform:f30) needed by module fish:3:3020190301191132:602da195-0.x86_64
 Problem 30: conflicting requests
  - nothing provides module(platform:f30) needed by module libgit2:0.27:3020190304180745:a5b0195c-0.x86_64
 Problem 31: conflicting requests
  - nothing provides module(platform:f30) needed by module minetest:5:3020190308194723:a5b0195c-0.x86_64
 Problem 32: conflicting requests
  - nothing provides module(platform:f30) needed by module ninja:latest:3020190304180949:a5b0195c-0.x86_64
 Problem 33: conflicting requests
  - nothing provides module(platform:f30) needed by module standard-test-roles:3.0:3020190319161255:a5b0195c-0.x86_64
Dependencies resolved.
====================================================================================================================================
 Package                             Architecture           Version                                   Repository               Size
====================================================================================================================================
Upgrading:
 container-selinux                   noarch                 2:2.101-1.gitb0061dc.fc30                 updates                  47 k
 dbus-broker                         x86_64                 21-3.fc30                                 updates                 161 k
 dbus-glib                           x86_64                 0.110-5.fc30                              updates                 115 k
 flatpak                             x86_64                 1.2.4-3.fc30                              updates                 1.1 M
 flatpak-libs                        x86_64                 1.2.4-3.fc30                              updates                 345 k
 gnome-calendar                      x86_64                 3.32.2-1.fc30                             updates                 562 k
 mesa-dri-drivers                    x86_64                 19.0.4-1.fc30                             updates                  14 M
 mesa-filesystem                     x86_64                 19.0.4-1.fc30                             updates                  18 k
 mesa-libEGL                         x86_64                 19.0.4-1.fc30                             updates                 108 k
 mesa-libGL                          x86_64                 19.0.4-1.fc30                             updates                 149 k
 mesa-libOpenCL                      x86_64                 19.0.4-1.fc30                             updates                 319 k
 mesa-libgbm                         x86_64                 19.0.4-1.fc30                             updates                  38 k
 mesa-libglapi                       x86_64                 19.0.4-1.fc30                             updates                  36 k
 mesa-libxatracker                   x86_64                 19.0.4-1.fc30                             updates                 1.2 M
 mesa-vulkan-drivers                 x86_64                 19.0.4-1.fc30                             updates                 1.9 M

Transaction Summary
====================================================================================================================================
Upgrade  15 Packages

Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:

**CLI ENDS**

Version-Release number of selected component (if applicable):

Not really applicable but :
**CLI BEGINS**
dnf --version                                                                                                       
4.2.5
  Installed: dnf-0:4.2.5-1.fc30.noarch at Fri 10 May 2019 12:17:48 GMT
  Built    : Fedora Project at Tue 07 May 2019 15:11:38 GMT

  Installed: rpm-0:4.14.2.1-4.fc30.1.x86_64 at Wed 03 Apr 2019 12:19:06 GMT
  Built    : Fedora Project at Sat 02 Feb 2019 18:46:11 GMT

**CLI ENDS**

How reproducible:
Guaranteed


Steps to Reproduce:
1.dnf update or similar.
2.
3.

Actual results:

See above CLI


Expected results:

Not expecting conflicts.
This output dates from today. I don't currently have ANY modular packages installed. I had removed ripgrep and fd-find in a first attempt to solve the problem.


Additional info:

At the time of first appearance, I had two modules installed. ripgrep and fd-find.
I tried deleting the entire dnf cache on /var/cache/dnf/* but that didn't help: it was rebuilt but the conflicts persisted.
I tried removing all the modules installed (dnf list installed | grep modul) which were ripgrep and fd-find as stated, to try to find something a little more helpful. Conflicts notifications persist and unchanged.

Although it seems like the old bug, my os-release is unchanged and is currently:

**CLI BEGIN**
cat /etc/os-release                                                                                            

NAME=Fedora
VERSION="30 (Workstation Edition)"
ID=fedora
VERSION_ID=30
VERSION_CODENAME=""
PLATFORM_ID="platform:f30"
PRETTY_NAME="Fedora 30 (Workstation Edition)"
ANSI_COLOR="0;34"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:30"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f30/system-administrators-guide/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=30
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=30
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Workstation Edition"
VARIANT_ID=workstation

**CLI END**

Comment 1 b0a387e2 2019-05-13 15:52:34 UTC
I have tried replacing my os-release with an f30 version of the https://huhuidong.wordpress.com/2018/12/19/modular-dependency-problems-conflicting-requests-fedora-29/ solution.
As expected it did not help.

Comment 2 b0a387e2 2019-05-18 11:43:19 UTC
This seems to be a related to : https://bugzilla.redhat.com/show_bug.cgi?id=1656509

I have upgraded from f29 but this error did **not** start appearing until some time after upgrade.
Sadly the bug report doesn't seem to be helpful in getting out of it; even though someone has tried to close the report as fixed!

Comment 3 b0a387e2 2019-05-18 11:56:38 UTC
Just realised that I followed the instructions that were on the https://fedoraproject.org/wiki/DNF_system_upgrade .
These instructions included a reference to the modules version in the "dnf system upgrade" command and it has subsequently been removed.

Comment 4 b0a387e2 2019-05-18 12:02:49 UTC
I used "sudo dnf system-upgrade download --refresh --releasever=30 --setopt='module_platform_id=platform:f30'" as instructed.
Starting to think this is a red herring and something changed (badly) at the repo end.

Comment 5 b0a387e2 2019-05-18 12:42:39 UTC
Seems to be down to modules and Rawhide interaction.
Once I disabled the rawhide repo - from which I only enable access to one package, btrfs-tools, in the ".repo" file - the issue disappears.

If this bug is feature of Rawhide - the developers test area - how do we put faith in the whole concept of modularity within Fedora stable?

Comment 6 b0a387e2 2019-05-18 12:58:32 UTC
http://fedora.12.x6.nabble.com/Trying-a-upgrade-from-29-to-30-tp5083088p5083115.html provides the clue for me to try turning the rawhide repo off.

** CLI BEGINS **
$ cat sudo cat /etc/yum.repos.d/fedora-rawhide.repo

<snip>

[rawhide]
name=Fedora - Rawhide - Developmental packages for the next Fedora release
failovermethod=priority
#baseurl=http://download.fedoraproject.org/pub/fedora/linux/development/rawhide//Everything/$basearch/os/
metalink=https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=$basearch
enabled=0
metadata_expire=6h
repo_gpgcheck=0
type=rpm
# gpgcheck=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-$releasever-$basearch
# skip_if_unavailable=False
skip_if_unavailable=True
# Added from https://dnf.readthedocs.io/en/latest/conf_ref.html#conf-ref-label
includepkgs=btrfs-progs 

<snip>

Why did this problem only just reappear recently - (long) after my successful upgrade to f30? That must mean that the Rawhide repo metadata was "good" at one stage (and for a while) with f30

Comment 7 Jaroslav Mracek 2019-06-03 19:13:02 UTC
The behavior is a consequence of https://github.com/rpm-software-management/libdnf/commit/add998a2afabead4beaeeb91727a5389d7d5a859.

Comment 8 Jaroslav Mracek 2019-07-30 08:58:46 UTC
I create a patch (https://github.com/rpm-software-management/dnf/pull/1446) that change application of excludes/includes. It will resilt that excluded packages will be not used for detection of Platform ID

Comment 9 Jaroslav Mracek 2019-07-30 14:15:05 UTC
I also create a test for it - https://github.com/rpm-software-management/ci-dnf-stack/pull/580

Comment 10 b0a387e2 2019-07-30 17:39:04 UTC
Thank you @Jaroslav

I enabled the repo (package) again. And wait for it to come through!

Comment 11 Fedora Update System 2019-08-14 12:11:15 UTC
FEDORA-2019-40235845dc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 12 Fedora Update System 2019-08-16 19:50:22 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, dnf-plugins-extras-4.0.5-1.fc30, libdnf-0.35.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 13 Fedora Update System 2019-08-26 13:26:29 UTC
FEDORA-2019-40235845dc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 14 Fedora Update System 2019-08-27 18:21:27 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, dnf-plugins-extras-4.0.5-1.fc30, libdnf-0.35.2-1.fc30, swid-tools-0.8.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 15 Fedora Update System 2019-08-29 05:05:24 UTC
FEDORA-2019-40235845dc has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 16 Fedora Update System 2019-08-30 00:03:38 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, libdnf-0.35.2-1.fc30, swid-tools-0.8.6-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-40235845dc

Comment 17 Fedora Update System 2019-09-06 12:31:02 UTC
dnf-4.2.8-1.fc30, dnf-plugins-core-4.0.9-1.fc30, libdnf-0.35.2-1.fc30, swid-tools-0.8.6-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.