Bug 1709454 - Cluster Logging Operator is unable to create Fluentd due to missing RBAC for metadata-reader cluster role
Summary: Cluster Logging Operator is unable to create Fluentd due to missing RBAC for ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.z
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard: 4.1.4
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-13 15:43 UTC by ewolinet
Modified: 2019-07-08 14:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-04 09:01:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 175 None None None 2019-05-13 15:45:30 UTC
Github openshift cluster-logging-operator pull 178 None None None 2019-05-14 19:09:22 UTC
Red Hat Product Errata RHBA-2019:1635 None None None 2019-07-04 09:01:33 UTC

Description ewolinet 2019-05-13 15:43:44 UTC
Description of problem:
Cluster Logging Operator is missing appropriate RBAC definitions to be able to create the metadata-reader cluster role for log collection.


Version-Release number of selected component (if applicable):
4.1.0


How reproducible:
Always


Steps to Reproduce:
1. Configure the ClusterLogging CR to deploy Fluentd
2. Deploy Cluster Logging Operator
3. Tail Cluster Logging Operator logs and observe error message

Actual results:
Fluentd daemonsets can't be created due to missing RBAC

Expected results:
Fluentd daemonset is able to be created


Additional info:

Comment 1 Ben Parees 2019-05-14 14:56:27 UTC
Can someone summarize the impact of this bug?  If this is not fixed in 4.1.0, is it even possible to deploy the logging stack?  It sounds like no.

Comment 2 Anping Li 2019-05-15 06:51:58 UTC
QE did hit this issue using the latest origin and downstream images. @eric, What is the clusterversion and CLO Operator version?
Cluster version is 4.1.0-0.nightly-2019-05-14-202907
Orign:  openshift/origin-cluster-logging-operator:latest
Downstream: openshift/ose-cluster-logging-operator:v4.1.0-201905132354

Comment 3 ewolinet 2019-05-16 17:20:19 UTC
I hit this using a local build from master (release-4.1) for CLO deployed using the manifest csv 4.1.0.

Comment 4 Anping Li 2019-05-17 09:16:02 UTC
it is just specific to CI. If you deploy via OLM  following the use guide. you won't hit this issue. It is Ok to move to v4.1.z

Comment 7 errata-xmlrpc 2019-07-04 09:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:1635


Note You need to log in before you can comment on or make changes to this bug.