Bug 1709518 - Use ceph-iscsi package instead of ceph-iscsi-cli/config
Summary: Use ceph-iscsi package instead of ceph-iscsi-cli/config
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 4.0
Assignee: Mike Christie
QA Contact: Vasishta
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1730176
TreeView+ depends on / blocked
 
Reported: 2019-05-13 18:12 UTC by Mike Christie
Modified: 2020-01-31 12:46 UTC (History)
8 users (show)

Fixed In Version: ceph-ansible-4.0.0-0.1.rc10.el8cp
Doc Type: Enhancement
Doc Text:
.Ceph iSCSI packages merged into single package The `ceph-iscsi-cli` and `ceph-iscsi-config` packages have been merged to one package named `ceph-iscsi`.
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3977 0 None closed igw add support for ceph-iscsi package 2020-03-01 20:34:51 UTC
Github ceph ceph-ansible pull 4192 0 None closed igw add support for ceph-iscsi package (bp #3977) 2020-03-01 20:34:51 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:51 UTC

Description Mike Christie 2019-05-13 18:12:40 UTC
Description of problem:

The ceph-iscsi-config and ceph-iscsi-cli packages were merged into ceph-iscsi and the ceph-iscsi-config API was completely changed, but the ceph-ansible iscsi code/tasks will try to use ceph-iscsi with the old API calls and crash.

To handle all this issue we will sync non-container setup to work like container based setup where ansible is only used to setup the daemons and install rpms. gwcli or dashboard will then be used to setup the iscsi objects like the target, LUNs and clients.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Giridhar Ramaraju 2019-08-05 13:06:54 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 4 Giridhar Ramaraju 2019-08-05 13:09:30 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 9 errata-xmlrpc 2020-01-31 12:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.