Bug 1709693 - TASK - ceph-mgr : install ceph-mgr packages is failing
Summary: TASK - ceph-mgr : install ceph-mgr packages is failing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 4.0
Assignee: Timothy Asir
QA Contact: Uday kurundwade
Anjana Suparna Sriram
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-05-14 07:33 UTC by Uday kurundwade
Modified: 2020-02-08 09:39 UTC (History)
6 users (show)

Fixed In Version: ceph-14.2.1-124.g35e6f59
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:46:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:46:51 UTC

Description Uday kurundwade 2019-05-14 07:33:11 UTC
Description of problem:
TASK - ceph-mgr : install ceph-mgr packages is failing

Version-Release number of selected component (if applicable):
ceph-ansible-4.0.0-0.1.rc6.el8cp.noarch
ansible-2.8.0-0.8.rc1.el8ae.noarch

How reproducible:
Always

Steps to Reproduce:
1.run playbook
2.
3.

Actual results:
TASK [ceph-mgr : install ceph-mgr packages on RedHat or SUSE] *****************************************************************************************************************************************************
Monday 13 May 2019  06:41:46 +0000 (0:00:00.230)       0:03:47.933 ************ 
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (3 retries left).
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (2 retries left).
FAILED - RETRYING: install ceph-mgr packages on RedHat or SUSE (1 retries left).
fatal: [magna033]: FAILED! => changed=false 
  attempts: 3
  failures: []
  msg: |-
    Depsolve Error occured:
     Problem: conflicting requests
      - nothing provides python3-routes needed by ceph-mgr-dashboard-2:14.2.1-3.el8cp.noarch
  rc: 1
  results: []

Expected results:
Playbook should pass successfully.

Additional info:

Comment 1 Timothy Asir 2019-09-03 08:05:23 UTC
Package dependency is added in the spec file (dist git branch ceph-4.0-rhel-8.

Comment 7 errata-xmlrpc 2020-01-31 12:46:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.