Bug 170979 - cpuspeed initscript causes fatal error message by modprobe acpi-cpufreq on an Athlon CPU
cpuspeed initscript causes fatal error message by modprobe acpi-cpufreq on an...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cpuspeed (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-16 16:28 EDT by Peter Bieringer
Modified: 2015-01-04 17:22 EST (History)
14 users (show)

See Also:
Fixed In Version: cpuspeed-1.2.1-1.46.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-09 03:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dell Latitude C600 dmesg with kernel-2.6.14-1.1637_FC4 (13.42 KB, text/plain)
2005-11-11 18:35 EST, Andrew Smith
no flags Details
silences the fallback modprobe attempt (387 bytes, patch)
2005-11-23 01:57 EST, Thomas M Steenholdt
no flags Details | Diff

  None (edit)
Description Peter Bieringer 2005-10-16 16:28:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:


Version-Release number of selected component (if applicable):
cpuspeed-1.2.1-1.23_FC4 kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. Use desktop system with Athlon CPU
2. Do not disable cpuspeed on bootup

  

Actual Results:  FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.13-1.1526_FC4/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

Expected Results:  Not such fatal error message

Additional info:

# cat /proc/acpi/processor/CPU0/info
processor id:            0
acpi id:                 0
bus mastering control:   no
power management:        yes
throttling control:      no
limit interface:         no

# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 6
model name      : AMD Athlon(tm) XP 1700+
stepping        : 2
cpu MHz         : 1460.797
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips        : 2924.66



# modprobe acpi-cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.13-1.1526_FC4/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

Looks like /etc/rc.d/init.d/cpuspeed should be more smarter.
Comment 1 Kenneth Porter 2005-10-22 02:40:13 EDT
Still the case with release 1.1532. System is DFI LANParty UT with AMD64 Venice
3000. Bug 168465 and bug 165494 may be related. Hardware for these should be
changed to Athlon.
Comment 2 Andre Robatino 2005-10-25 18:11:14 EDT
  If I'm not missing something, this looks to me like an exact dup of bug
#165494.  And my father experiences it on an Emachines 300k which has an i586
CPU (an AMD K6-2, I think).
Comment 3 Duane Laurent 2005-10-29 12:52:56 EDT
Same problem here with no-name clone running 2GHz Pentium on both the
2.6.13-1.1526_FC4 and 2.6.13-1.1532_FC4 kernels.

# cat /proc/acpi/processor/CPU0/info
processor id:            0
acpi id:                 1
bus mastering control:   no
power management:        yes
throttling control:      yes
limit interface:         yes

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 2.00GHz
stepping        : 4
cpu MHz         : 2020.363
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm
bogomips        : 4046.21

# modprobe acpi_cpufreq
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.13-1.1532_FC4/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
Comment 4 Heiko Adams 2005-10-30 03:25:51 EST
Same problem here. CPU is an Intel Celeron M 1.5 GHz and kernel is
2.6.13-1.1526_FC4 and 2.6.13-1.1532_FC4.

#cat /proc/acpi/processor/CPU0/info
processor id:            0
acpi id:                 0
bus mastering control:   no
power management:        yes
throttling control:      yes
limit interface:         yes

#cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Celeron(R) M processor         1.50GHz
stepping        : 8
cpu MHz         : 1496.554
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss tm pbe
bogomips        : 2998.24

# modprobe acpi_cpufreq
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.13-1.1532_FC4/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device
Comment 5 Andrew Smith 2005-11-11 18:32:34 EST
Same problem with 2 machines

I initially posted this in Bug #165494
but obviously this one is the correct bug (exactly the same)

1) Dell Latitude C600 - should not get error?
2) Noname pre 2000 Bios warning Desktop - I guess the error doesn't matter - but
not sure why it is trying to load acpi-cpufreq.ko (2.6.13-1.1532_FC4)

All following info is regarding "1) Dell Latitude C600":

Occurs with 2.6.14-1.1637_FC4
Also occurred with 2.6.13-1.1532_FC4 and probably all previous FC4?
Also occurred with 2.6.11-1.1369_FC4

# cat /proc/acpi/processor/CPU0/info
processor id:            0
acpi id:                 1
bus mastering control:   yes
power management:        yes
throttling control:      no
limit interface:         no

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 852.084
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
mmx fxsr sse
bogomips        : 1706.10


Is this due to no support for the Dell C600 (too old?)

Attachment follows for dmesg on 2.6.14-1.1637_FC4
Comment 6 Andrew Smith 2005-11-11 18:35:08 EST
Created attachment 120969 [details]
Dell Latitude C600 dmesg with kernel-2.6.14-1.1637_FC4
Comment 7 Doug Dalton 2005-11-15 16:19:06 EST
I have the same error on a dual Xeon 3.6 ghz supermicro cse-813-500b 
Comment 8 Thomas M Steenholdt 2005-11-23 01:57:18 EST
Created attachment 121387 [details]
silences the fallback modprobe attempt

The error occurs because cpuspeed tries to load "acpi-cpufreq" as FALLBACK
cpufreq module and fails on machines that this driver does not work with. This
is intended behaviour if /etc/cpuspeed.conf has not been correctly configured
with a DRIVER="somedriver" option.
Now, wether the "acpi-cpufreq" module SHOULD work with these systems is the
real question here.
In any case i suggest silencing the warning exactly since it's the FALLBACK
driver and we have no idea if it should load or not.
Comment 9 Thomas M Steenholdt 2005-11-23 02:01:42 EST
Please rebase to devel as this problem is also in rawhide.
Comment 10 Kenneth Porter 2005-11-23 18:39:43 EST
Comment 1 resolved in bug 173289. The problem was a BIOS missing required ACPI
tables, which was resolved by updating the BIOS. The powernow-k8 module now
initializes successfully, so the fallback driver isn't needed.
Comment 11 Kasper Dupont 2005-11-25 02:46:30 EST
I see the same error message on a Compaq Presario 2166EA.

[kasperd@erwin:pts/3:~] cat /proc/acpi/processor/CPU0/info 
processor id:            0
acpi id:                 0
bus mastering control:   yes
power management:        yes
throttling control:      yes
limit interface:         yes
[kasperd@erwin:pts/3:~] cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Mobile Intel(R) Celeron(R) CPU 2.20GHz
stepping        : 7
cpu MHz         : 2193.141
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips        : 4393.77
Comment 12 Kenneth Porter 2005-11-25 12:45:21 EST
As suggested in bug 173289, booting with cpufreq.debug=7 may reveal more hints
about why the native CPU speed control driver isn't loading.
Comment 13 Kasper Dupont 2005-12-02 05:44:57 EST
I tried booting with cpufreq.debug=7 and found this in the dmesg output:

acpi-cpufreq: acpi_cpufreq_init
cpufreq-core: trying to register driver acpi-cpufreq
cpufreq-core: adding CPU 0
acpi-cpufreq: acpi_cpufreq_cpu_init
acpi-cpufreq: acpi_processor_cpu_init_pdc
cpufreq-core: initialization failed
cpufreq-core: no CPU initialized for driver acpi-cpufreq
cpufreq-core: unregistering CPU 0
Comment 14 dennis_wilson 2005-12-05 08:07:02 EST
I'm experiencing the same error, on a Compaq EN. 
I have tried various (obvious) fixes, modifying modprobe.conf
cpuspeeed.conf...all to no avail.
Comment 15 MASAO TAKAHASHI 2006-02-04 02:04:04 EST
Does p4-clockmod.c have a bug as follows ?
linux-2.6.14-1.1905_FC5
-----------------------------------------------------------------------------
line 243-line 251
/* table init */
 for (i=1; (p4clockmod_table[i].frequency != CPUFREQ_TABLE_END); i++) {
   if ((i<2) && (has_N44_O17_errata[policy->cpu]))
     p4clockmod_table[i].frequency = CPUFREQ_ENTRY_INVALID;
   else if (has_N60_errata[policy->cpu] && p4clockmod_table[i].frequency < 2000000)
     p4clockmod_table[i].frequency = CPUFREQ_ENTRY_INVALID;
   else
     p4clockmod_table[i].frequency = (stock_freq * i)/8;
  }
--------------------------------------------------------------------------------
If my CPU has N60 errata, 
then all the entries of p4clockmod_table are invalidated.
Because the p4clockmod_table.frequency entries have already initialized to 0.

Don't you think so ?
Comment 16 MASAO TAKAHASHI 2006-02-04 03:21:07 EST
(In reply to comment #15)
> Does p4-clockmod.c have a bug as follows ?
> linux-2.6.14-1.1905_FC5

I correct to linux-2.6.15-1.1905_FC5
                       ^^^
> -----------------------------------------------------------------------------
> line 243-line 251
> /* table init */
>  for (i=1; (p4clockmod_table[i].frequency != CPUFREQ_TABLE_END); i++) {
>    if ((i<2) && (has_N44_O17_errata[policy->cpu]))
>      p4clockmod_table[i].frequency = CPUFREQ_ENTRY_INVALID;
>    else if (has_N60_errata[policy->cpu] && p4clockmod_table[i].frequency <
2000000)
>      p4clockmod_table[i].frequency = CPUFREQ_ENTRY_INVALID;
>    else
>      p4clockmod_table[i].frequency = (stock_freq * i)/8;
>   }
> --------------------------------------------------------------------------------
> If my CPU has N60 errata, 
> then all the entries of p4clockmod_table are invalidated.
> Because the p4clockmod_table.frequency entries have already initialized to 0.
> 
> Don't you think so ?
> 

Comment 17 Dave Jones 2006-02-07 16:58:08 EST
we only invalidate entries in the table <=2GHz on CPUs with that bug.
it's also completely unrelated to this bugzilla.
Comment 18 Alexei Podtelezhnikov 2006-02-12 12:14:58 EST
In spite of the recent update to cpuspeed, FATAL error persists   
  
FATAL: Error inserting acpi_cpufreq 
(/lib/modules/2.6.15-1.1831_FC4/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): 
No such device 
 
[apodtele@somehost ~]$ rpm -q --changelog  cpuspeed-1.2.1-1.24_FC4   
* Fri Dec 23 2005 Dave Jones <davej@redhat.com>   
- Reset speed to max on deamon exit.   
- Don't load acpi-cpufreq if no throttling states exist.  
 
Maybe next update?  
  
   
   
   
     
Comment 19 Dave Jones 2006-02-20 21:12:31 EST
Strange.
What does the output of cat /proc/acpi/processor/*/throttling  say ?
Comment 20 Kasper Dupont 2006-02-20 23:36:09 EST
On a Presario 2166EA running 2.6.15-1.1831_FC4:

cat /proc/acpi/processor/*/throttling
state count:             8
active state:            T0
states:
   *T0:                  00%
    T1:                  12%
    T2:                  25%
    T3:                  37%
    T4:                  50%
    T5:                  62%
    T6:                  75%
    T7:                  87%
Comment 21 Dave Jones 2006-02-20 23:56:07 EST
Kasper, do you get the same messages with cpufreq.debug=7 as before, or is there
anything extra there on the newer kernel ?

Alexei, I'd like to see your /proc/acpi/processor/*/throttling too please.
Comment 22 Kasper Dupont 2006-03-03 07:08:08 EST
With 2.6.15-1.1833_FC4 and cpufreq.debug=7 I get exactly the same output as before.
Comment 23 Volker 2006-11-18 17:26:55 EST
The same with 2.6.18-1.2849.fc6
Comment 25 Peter Bieringer 2007-04-11 09:28:36 EDT
On a current FC6 system, this problem is gone.

cpuspeed-1.2.1-1.46.fc6
kernel-2.6.20-1.2933.fc6

# cpuspeed
Error: Could not open file for writing:
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory

So imho this bug can be closed now, the original reason is solved.

Note You need to log in before you can comment on or make changes to this bug.