Bug 17098 - macros broken?
Summary: macros broken?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-29 23:22 UTC by compwiz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-29 23:22:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description compwiz 2000-08-29 23:22:06 UTC
Whenever doing something with latest CVS rpm (e.g. querying a package), i
get the following message:


*** rpmReadConfigFiles((null),(null))
/usr/lib/rpm/macros:/usr/lib/rpm/%{_target}/macros:/etc/rpm/macros:/etc/rpm/macros.specspo:/etc/rpm/%{_target}/macros:~/.rpmmacros
*** rpmRebuildTargetVars(0xbffff744) (null)
*** _target_cpu: "i686"
*** _target_os: "linux"
*** _target: "i686-linux"
*** rpmRebuildTargetVars(0xbffff744) (null)
*** _target_cpu: "i686"
*** _target_os: "linux"
*** _target: "i686-linux"

-----------------

This seems to be related to the fact that %{optflags} is never set, which
makes it nearly impossible to build most RPMs. I'm running on an Athlon,
and built RPM myself.

Comment 1 Jeff Johnson 2000-08-30 13:46:55 UTC
You are building rpm-4.1 which is broken now (and breakage will proceed).

Try the rpm-4_0 branch:
	cvs up -r rpm-4_0



Note You need to log in before you can comment on or make changes to this bug.