Bug 170984 - Opendocument import filter plugin missing
Opendocument import filter plugin missing
Status: CLOSED DUPLICATE of bug 161832
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marc Maurer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2005-10-16 20:04 EDT by Jonathan Underwood
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-17 08:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
AbiWord.Profile (14.60 KB, text/plain)
2005-10-17 07:03 EDT, Jonathan Underwood
no flags Details

  None (edit)
Description Jonathan Underwood 2005-10-16 20:04:09 EDT
Description of problem:
Abiword 2.4(.1) has an import filter for opendocument which is a plugin, but is
missing from the 2.4.1 rpm

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
2.No opendocument import
Actual results:

Expected results:

Additional info:
Comment 1 Marc Maurer 2005-10-17 05:38:13 EDT
Hmmm. I added it in 2.4.1, it was indeed missing from 2.4.0. Sure it does not
load? Extra -> Plugins should list it. If not, could you send me
~/.AbiSuite/AbiWord.Profile ?
Comment 2 Jonathan Underwood 2005-10-17 07:03:32 EDT
Created attachment 120047 [details]
Comment 3 Jonathan Underwood 2005-10-17 07:06:59 EDT
The Tools->Plugins dialogue box does not list the opendocument plugin. See the
above attachment of the file you requested, and notably the lines:
        <!-- [Mon 17 Oct 2005 11:59:37 AM BST] message:
XAP_ModuleManager::loadModule - (L119): loading
/usr/lib/AbiWord-2.4/plugins/libAbiHRText.so -->
        <!-- [Mon 17 Oct 2005 11:59:37 AM BST] message:
XAP_ModuleManager::loadModule - (L158): failed to load
/usr/lib/AbiWord-2.4/plugins/libAbiHRText.so -->
        <!-- [Mon 17 Oct 2005 11:59:37 AM BST] message:
XAP_ModuleManager::loadModule - (L164): error msg
/usr/lib/AbiWord-2.4/plugins/libAbiHRText.so: undefined symbol: __dso_handle -->
Comment 4 Marc Maurer 2005-10-17 08:48:53 EDT
Thanks. This is a dupe of 161832. Will invesitgate what the actual cause is.

*** This bug has been marked as a duplicate of 161832 ***

Note You need to log in before you can comment on or make changes to this bug.